Skip to Content
author's profile photo Former Member
Former Member

Custom field of MVKE is not updating in production server thriugh BAPI_MATERIAL_SAVEDATA

Hi All,

Custom field of MVKE is not updating in production server thriugh BAPI_MATERIAL_SAVEDATA ,But in development and quality ,per production server

it is updation.

This bapi ( executable program )called from Workflow task using submit report.

And I have checked the WF-BATCH ( user id of WF )

role in production and development and quality , it have SAP_ALL access and not difference in Role across server.

Please help me.

Thanks in advance

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • Posted on Dec 16, 2015 at 11:01 PM

    Have you figured this out? I have having the same problem. I'm using BAPI_MATERIAL_SAVEDATA to update a single field. WF-BATCH has SAP_ALL & SAP_NEW.

    When I run it as a background task it does not work. When I change the task to be a dialog task so that I can debug it, it will work.


    Untitled.png (16.5 kB)
    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Dec 17, 2015 at 07:06 AM

    Hi,

    There is a note for the issue. Please check OSS Note # 914251 .

    Regards,

    Renjith

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.