Skip to Content
0
Former Member
Apr 30, 2014 at 09:01 AM

COPA Report current period and previous period issue

317 Views


Hi Gurus,

I have defined COPA report (Tcode KE94) based on line items. Now I want all values to be displayed based on an entry parameter in terms of period. That is to say that If I give input values of "010.2013" as a period entry , my report should display the values for the the period specified i.e. 010.2013 in the first column and in second column values for the period 009.2013 should be displayed and in the third column values for the period 001.2013 till 010.2013 should be displayed cumulatively.

For this, I choosed the character "period/year" in General data selection tab, clicked "Variable on/off" tab and gave values "From" as well as "To" for the Global Variable "OFP" which is Curr.fisc.per./year.

For the 1st column (1st column which is suppose to display the values according to selection parameter), along with the character "company code" , I choosed the character "period" and clicked "Variable on/off" tab and gave value "From" as well as "To" for the Global Variable "OFP" which is Curr.fisc.per./year.

For the 2nd column (2nd column which is suppose to display the values for the immediately preceeding period of the selection parameter), along with the character "company code" , I choosed the character "period" and clicked "Variable on/off" tab and gave value "From" as well as "To" for the Global Variable "OFP" which is Curr.fisc.per./year. While doing so, I selected operator as "-" and choosed offset as 1.

For the 3rd column (3rd column which is suppose to display the cumulative values from the beginning of the fiscal year till the period mentioned in the selection parameter), along with the character "company code" , I choosed the character "period" and selected 001 in "From" and 016 in "To" tab.

Company Code selected in all the three columns is same and I have selected actual values i.e. 0 for "plan/actual indicator" tab.

When I run the report through Tcode KE30 , I give values as "010.2013" for the From and To selection tabs. System shows the values as per the selection parameter in the 1st column which is correct but display values same as per coulmn 1st in the 3rd column which is wrong because it should be cumulative. 2nd column is blank.

How to display the values for the immediately preceeding period and for cumulative period?

Regards,

makrand