Skip to Content
0
Apr 29, 2014 at 05:15 AM

UWL API : execution URLs of custom connector mismatched

15 Views

Hello,

[Portal version: CE7.3 EhP1 SP9]

I am facing a weird issue in reading execution URL of a custom UWL connector in Web Dynpro Java code.

There is a custom UWL Connector implemented and inside its getItems() method, I am connecting to provider system and looping over the list of tasks that are returned and creating UWL items as following: -

//inside for-loop

Item uwlItemCRM = null;

uwlItemCRM = new Item(CRMUwlConnector.CONNECTOR_ID,

system,

MYEXTERNALID+i,

userID,

-1,

creationDate,

creator-id,

null,

"EXT_OBJID",

"EXT_TYPE",

myItemTypes[0],

taskPriority,

StatusEnum.NEW,

taskDesc);

uwlItemCRM.setCreatorId(taskType);

uwlItemCRM.setDescription(taskDesc);

uwlItemCRM.setExecutionUrl(actionURL);

Each workitem created here has unique execution URL. ( I have printed this in logs and confirmed).

And now in Web Dynpro Java DC, I'm using following lines to fetch UWL tasks: -

UWLView uwlView = uwlService.getViewManager(uwlContext).getView("DefaultView", uwlContext);

IUWLItemManager itemManager = uwlService.getItemManager(uwlContext);

QueryResult queryResult = itemManager.refreshCacheAndGetItems(uwlContext, uwlView, null, p_compoundExpression);

ItemCollection results = queryResult.getItems();

But when I loop and print execution URLs of workitems that I get here, they are incorrect to what has been set inside UWL Connector code.

However, if I just clear connector cache using System Admin > UWL Admin, it works fine for some time. But again after an hour or so, this mix up starts happening again.

Any idea what might be going wrong here?

Please help.

Thanks & Regards,

Amey Mogare