Skip to Content
0

help with a cascade filter in SAP Design studio 1.6

Jan 19, 2017 at 05:59 PM

245

avatar image

Good day:

I'm having an issue with a dashboard made in design studio 1.6.

In the dashboard I have several dropdowns that are filled in cascada with the values depending on the value selected in other dropdown.

The issue I'm having is that in certain combinations the dropdown shows more lines that the ones in the data source (see the images attached)

This is the dropdown where you can see that it has more than 9 values

And this is the crosstab with the data source where you can see that it has only 8 values (the ones that should had been shown in the dropdown)

I checked in the data source and the dimension has selected the option "Only values in posted data".

The thing that leave me with doubts is that the dropdown only works when I bind it with the data source 1 and the dimension is shown in the rows.

Can anyone help me to solve this issue because I use the DS_1 in almost the entire dashboard and I can't put the dimension in the rows.

Thanks in advance for any help.

Greetings

dropdown.png (3.8 kB)
data-source.png (1.8 kB)
10 |10000 characters needed characters left characters exceeded

Can you share more details - is your data source a universe, BEx query, or? Share your binding / properties screens?

If it is a universe please check this: https://blogs.sap.com/2014/05/29/how-to-create-multiple-dropdown-boxes-cascading-filters-when-using-bo-universe-in-the-backend/

If not see https://blogs.sap.com/2012/12/30/business-value-of-setting-up-cascading-filters/

0

Hi Tammy!!... thanks for the answer.

I'm using a BEx query, here are the screens of the data source where the "only values with posted data" is checked and the binding properties for the dropdown.

Data source:

Dropdown properties:

The extrange thing to me is that it works but only if I put the dimension on the rows of the DS_1, if I do it on another data source it won't work even if I put the dimension on the rows.

I don't know if there is any property that I'm missing in the BEx query or in Design Studio that is giving me this problem.

Thanks for helping me.

Greetings

ds.png (26.8 kB)
binding.png (16.1 kB)
0
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Tammy Powlas
Jan 19, 2017 at 10:31 PM
0

I see - you are binding the display on the dropdown

I am updating the On Select for events to populate

DS_1.setFilter("ZPROJ", DROPDOWN_1.getSelectedValue()); DROPDOWN_1.setItems(DS_1.getMemberList("ZPROJ", MemberPresentation.INTERNAL_KEY, MemberDisplay.TEXT, 5, "ALL"));

Any thoughts to trying that approach? The cascading then works for me.


1and.jpg (61.4 kB)
Show 1 Share
10 |10000 characters needed characters left characters exceeded

Thanks Tammy:

I've already tried with the event on select, when I made the dashboard I use the code because I didn't have the knoledge of the data binding property, and because a requirement that the dropdown shows an empty value at the begining I have to populate it with code, this is the code that I used:

When I did the tests I didn't have the problem because it only happens in certain filters, with another combination the dropdown populates as suposed.

When I have the knoledge about the problem I tried all the options that I was able and it allways sows more items that it should, just as a test I tried with the binding properties and that was when it works fine but only if I put the dimension on the rows and only if I do this in the DS_1.

What I'm seeing is that in the data source I have a dimension that is an atribute of the custommer and other that is an attribute of the bill and the dropdown is getting the items of both even though I'm filling it only with the one of the custommer.

I just did a test and removed the dimension of the bill from the BEx query and then reset the initial view of the data source in Design but the dropdown is filled with more items.

I think that the problem might be on the data source or in the BEx query, but the strange thing is that if I run the query on a BEx Analyzer or if I put the data source (in design) in a crosstab in both scenarios shows the correct values, only when filling the dropdown is when the items are mixed with the ones from both dimensions.

codigo.png (6.6 kB)
0