Skip to Content
0
Former Member
Apr 24, 2014 at 07:01 AM

Oracle installer fails to start due to permission errors

715 Views

Hi,Recently I was doing the Oracle 11g installation in AIX 7.1 and faced a problem with Oracle installer not being able to start and perform installation.

The RUNINSTALLER errors are as below :

Has 'rootpre.sh' been run by root? [y/n] (n)y

Error returned::: No such file or directoryPermission deniedsh: /command_output_4522380: cannot createPermission deniedsh: /command_output_4522380: cannot createPermission deniedsh: /command_output_4522380: cannot createError in GetCurrentDir(): 13Error in GetCurrentDir(): 13Error in GetCurrentDir(): 13Error in GetCurrentDir(): 13Starting Oracle Universal Installer...Checking temp space: 0 MB available, 190 MB required. Failed <<<<Checking swap space: 0 MB available, 150 MB required. Failed <<<<Checking monitor: must be configured to display at least 256 colors >>> Could not execute /usr/bin/X11/xdpyinfo Failed <<<<

Log of rootpre.sh -->

./rootpre.sh output will be logged in /tmp/rootpre.out_14-04-23.12:43:50/bin/uname -a: AIX pidbcid1 1 7 00F6DA9E4C00OSVER: 7OSREL: 1

Environment:------------_=/bin/envMANPATH=/opt/quest/man:LANG=CLOGIN=rootCLCMD_PASSTHRU=1PATH=/usr/bin:/etc:/usr/sbin:/usr/ucb:/usr/bin/X11:/sbin:/usr/java5/jre/bin:/usr/java5/bin:/usr/symcli/bin:/usr/opt/ifor/ls/os/aix/bin:/opt/quest/bin:/opt/quest/libexec/oat:/opt/quest/libexec/vas:/opt/quest/libexec/vas/scripts:/usr/java14_64/jre/bin:/usr/java14_64/bin:/usr/lpp/admsnap:/usr/local/bin:/usr/local/avamar/bin:/usr/local/avamar/bin:/usr/local/avamar/bin:/usr/local/avamar/bin:/usr/local/avamar/binLC_ALL=CLC__FASTMSG=trueHISTFILE=/var/hist/root/.sh_history.ds1adm:rootLOGNAME=rootMAIL=/usr/spool/mail/rootLOCPATH=/usr/lib/nls/locUSER=rootAUTHSTATE=filesSHELL=/usr/bin/kshODMDIR=/etc/objreposHOME=/.rootTERM=xtermMAILMSG=[YOU HAVE NEW MAIL]PWD=/oracle/stage/112_64/databaseTZ=EST5EDTA__z=! LOGNAMENLSPATH=/usr/lib/nls/msg/%L/%N:/usr/lib/nls/msg/%L/%N.cat:/usr/lib/nls/msg/%l.%c/%N:/usr/lib/nls/msg/%l.%c/%N.cat------------

Checking if group services should be configured....ODMDIR=/etc/objrepos, isHACMP= 0Nothing to configure.

I tried checking the permission in tmp folder and also for oracle folders but all seems fine.

Can someone provide resolution steps ?

Regards,

Anupam