Skip to Content
avatar image
Former Member

Portal Rule Collection is not working for themes after upgrade to 7.4

Hi Gurus,

Recently we upgraded our portal server to SAP EP 7.4 SP05. After upgrade, the themes are not loaded based on the portal rule collection. Whatever the rule collection we specify, the portal loads the custom theme we have created.

The hierarchy of the rules, permissions seems to be fine.

We have also cleared the navigation, pcd cache but still facing the same issue.

Please let me know if you have any resolution for this or faced the issue yourself.

Thank you.

Regards

Rakesh

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • Best Answer
    avatar image
    Former Member
    Apr 29, 2014 at 10:22 AM

    Hi Rakesh,

    In master rule collection you indeed configure the rules for displaying desktops, according to priority top down - 1st rule that apply.

    In the desktop that fits the rule, make sure the desired theme is selected as default. (as there can be more than 1 theme in desktop).

    More on master rule collection:

    https://help.sap.com/saphelp_nw73/helpdata/en/48/1d5cfe71364269e10000000a421937/content.htm?frameset=/en/48/1d5cfe713642…

    Best Regards,

    Tal

    Add comment
    10|10000 characters needed characters exceeded

    • We had the same problem and resolved it using this solution.  Thanks very much.

      (we renamed the folder first to check that it was actually rebuilt during the startup process, which it was)


  • Apr 25, 2014 at 07:06 AM

    Try to launch the portal with /irj/portal?theme=sap_tradeshow (or some other theme). Does that work?

    Also when you try it, close your browser completely beforehand.

    Add comment
    10|10000 characters needed characters exceeded

  • Apr 23, 2014 at 08:24 PM

    Are you sure you are editing the right object? The correct one is pcd:portal_content/administrator/super_admin/main_rules.

    Add comment
    10|10000 characters needed characters exceeded

    • With display rules you assign portal desktops which contain a framework page and one or more portal themes. Make sure the portal theme is in included in the portal desktop. Do you have multiple themes in the portal desktop?

  • avatar image
    Former Member
    Jul 14, 2014 at 07:36 PM

    Glad it resolved your issue.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 22, 2014 at 10:30 AM

    Hi RakeshVarman,

    We have the same issue, portal upgrade to 7.02 to 7.4 , For few user Ajax theme is not working, When we copy the user having the issue and created a new user for them it is working fine.

    But my doubt why is not working for the current user only while copying the user it is working but logon id will be different.

    I have checked all the personalization and cleared all cache as well

    kindly provide your input ,client is forcing as to has ajax them.

    I have checked with standard ajax theme itself , same issue persist in that too.

    Thanks

    Sundar

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Sundar

      If its working for some users and not others, it might be a temporary server issue or might be an authorization issue.

      Try restarting the server after any theme changes.

      Also check whether the permissions at the root level has everyone group on it.

      Regards

      Rakesh