Skip to Content
author's profile photo Former Member
Former Member

BDC is not working in when executing the program in background

Hi gurus,

I have a problem that in BDC is not working when i'm executing the upload program in background thru scheduling(SM36) , while it works fine when i execute directly with NO screen display mode

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

5 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Nov 18, 2005 at 06:52 AM

    Can you explain the mode of upload?.

    If you are trying to upload the file from presentation server in background , it wont work .

    Instead using datasets, you can upload the files from application server in background.

    Regards

    Elini.P

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Nov 18, 2005 at 06:53 AM

    Many transactions behave differently when executed in foreground and background. The fields on the screen may be different.

    In transaction SHBD when starting a recording there is a checkbox where you can select 'Simulate Background Mode'. If you do your recording using this option you will get the code suitable for background mode. If you do not select this option you will get a code for foreground mode.

    By compairing the two codes you will know the changes required for background mode.

    Hope this helps you

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Nov 18, 2005 at 08:57 AM

    Did u Overcome any Warning Message When Executed through Process/foreground?

    In Background, Warning Messages should be avoided.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Nov 18, 2005 at 09:19 AM

    Hi Swatantra,

    If your input file is at presentation server you cant's access that in back ground mode. So please check that.

    Place the file in application server teh it will work.

    Thanks & Regards,

    Siri.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Nov 18, 2005 at 09:46 AM

    Hi while recording the transaction using SHDB u might not have checked the check box 'Simulate background mode' in the first screen.

    Please select this check box and do the recording. This will solve ur problem.

    Satish

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.