Skip to Content
author's profile photo Former Member
Former Member

No Approver found in the Access request for Risk owners?

Hi Team,

We have defined ABAP Class based for Agent Rule ZCL_GRAC_WFA_RISK_OWNER, and the Risk owners are also maintained in the AC table in Set-up, but after submitting the access request there are SOD voilations,Detour condition GRAC_MSMP_DETOUR_SODVIOL is satisfied , so the request is routed to ROLEAPP_SOD_PATH and parallely routed SODVIOL_DETOUR_PATH6,

Once the role owner approvers the request, and escape route applied at SODVIOL_DETOUR_PATH6 as No approver found.

But the Risk owners are defined in the AC Owner table.

Can anybody help with this, as why escape path is applied even after maintaining Risk owners?

Regards,

Sindhu

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • Posted on Sep 09, 2015 at 04:33 PM

    Hi Sindhu,

    Please check for the agent rule whether it is defined properly and picking the agent or not,normally this issue happens if the agent is not defined properly and system could not find the agent.

    Also activate the workflow which is also sometimes a reason for the issue.

    Additionally make sure the agent is defined both at the stage default settings and optional settings.

    Regards

    Pradeep

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Apr 17, 2014 at 07:21 PM

    Hi Sindhu,

    Please check the SoD violations in your request are coming from the roles present in the request or are from existing assignment of user.

    Note 1670504 provides 2 different risk owner agent ( lineitem level and request level ) . If your SoD violations are coming from existing assignment then you need to implement the second logic ( request level risk owner )

    Best Regards,

    Aman

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Sep 09, 2015 at 05:02 AM

    Hello,

    Risk owner has to be maintained in risk id under owner tab for that risk.

    then your agent rule will work.

    Regards,

    Prasant

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Ying,

      Please check your Risk owner agent rule "ZCL_GRAC_WFA_RISK_OWNER" and look for the logic used for routing to the correct SOX coordinator.

      You can also debug the session and check for the routing of the request.

      Regards,

      Sindhu

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.