Skip to Content

Error on exporting theme on themedesigner.dispatcher.hanatrial.ondemand.com

Hi.

Is there anyone getting this kind of error when exporting themes?

Thanks.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • Jan 20, 2017 at 11:10 AM

    Hi,

    I cannot reproduce it when creating a theme from scratch.

    Can you please describe your complete procedure and if you manually specified a SAPUI5 version? (Please copy your complete URL in your response).

    Best regards,

    Uwe

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Same problem, same procedure as MPRED.

      The full URL is just https://themedesigner-themedesigner.dispatcher.hanatrial.ondemand.com/index.html, I have not found a way to change the UI5 version.

      The error on the console looks like this:

      JSON generation failed for "UI5.sap/collaboration.mytheme.library". Requested JSON file "https://themedesigner-themedesigner.dispatcher.hanatrial.ondemand.com/themeroot/1.42.8/UI5/sap/collaboration/themes/sap_belize/library-parameters.json" of template theme does not exist.
      
      [SILENT ERROR] sap.theming.less.autorepair.MissingMetaDataException:"Theme" missing meta data in "UI5.sap/collaboration.sap_belize". Trying to repair.
        in code "sap.theming.less.StructureBundle.bApplyMetaData"
        while processing entity "UI5.sap/collaboration.sap_belize"
        at date "2017-01-21T04:22:34Z"
        with engine version "1.22.8"
      
      [SILENT ERROR] sap.theming.less.autorepair.MissingMetaDataException:"Theme" missing meta data in "UI5.sap/collaboration.sap_belize_plus". Trying to repair.
        in code "sap.theming.less.StructureBundle.bApplyMetaData"
        while processing entity "UI5.sap/collaboration.sap_belize_plus"
        at date "2017-01-21T04:22:34Z"
        with engine version "1.22.8"
      
      VM175:11 in file "https://themedesigner-themedesigner.dispatcher.hanatrial.ondemand.com/js/theming-engine/browser/ui/api-min.js" at line 38 column 1983 
      sap.theming.less.ImportCreationException:Creation of sap theme import is not supported yet.
        in code "sap.theming.less.UI5Framework.addFileImports"
        while processing entity "UI5.sap/collaboration.sap_belize_plus.library"
      <br>
  • Jan 20, 2017 at 11:10 AM

    Hi,

    I cannot reproduce it when creating a theme from scratch.

    Can you please describe your complete procedure and if you manually specified a SAPUI5 version? (Please copy your complete URL in your response).

    Best regards,

    Uwe

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 31, 2017 at 12:22 AM

    Hello everybody,

    I get the same error.

    My first theme of the day went ok and I could do want I wanted. Theme exported without any issue.

    After that, impossible to export any one of my themes I tried to create.

    All based on SAP Belize theme. I tried the UI theme designer from HCP, the one in the portal, directly from an app theme designer URL, same thing everywhere.

    I cleared all cache and allowed the memory from Chrome, still the same issue. I really thought it was that but, no.

    I am stuck here for now.

    Steps I do:

    - Create a new theme in the UI designer

    - Use the SAP belize as the base

    - Do some modifs (actually even if I do not do anything it does not export)

    - save draft

    - export..... Error.

    And when I go to my draft it tells: Theme is not created.

    Any help on this would be greatly appreciated.

    Thank you for your attention

    Best regards.

    Jacques-Antoine Ollier

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 31, 2017 at 03:45 PM

    Hi Everybody.

    I finally got it using the steps below mentioned:

    1) I created the theme, save it and we try to export the page displays the error as we know;

    2) I log out the page, log in again and selecte the theme already created but with error;

    3) After choose the theme i selected export and...worked.

    It's really strange but for me worked.

    Just give it a try and reply here.

    Regards.

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 31, 2017 at 07:20 PM

    Hello all,

    I think this is related to the memory of Chrome.It worked last night after I logged out and close Chrome completely and then I come back to create a new theme.

    Even though I clear the cache, cookies and session I still got the issue.

    However, when I close completely Chrome and then restart it, it works.

    As you said Mauricio, very strange.

    Best regards.

    Jacques-Antoine

    Add comment
    10|10000 characters needed characters exceeded