Skip to Content

Error “Object 'DM' (APCO) of type 'Application' is not available in version 'A'” while transporting process chain to production system.

Hi Gurus,

Whenever I try to transport a process chain ZFI_0FIGL_C10 from dev. to qua. & prod. the error “Object 'DM' (APCO) of type 'Application' is not available in version 'A'” is displayed in the end of creating transport package.

The process chain was created to load data to 0figl_c10 and it works all right on all systems (dev. qua. prod.).

The process chain contains processes for:

- starting the process chain

- executing infopackage (for loading data to 0figl_o10),

- ACR (activate data in 0figl_o10)

- delete index 0figl_c10

- DTP loading data from 0figl_o14 to 0figl_c10

- executing infopackage 80FIGL_O10

- creating index in 0figl_c10

- building DB statistics

- rolling up aggregates in 0figl_c10

- deleting of requests from the changelog 0figl_o10

- deleting of requests from PSA (0fi_gl_10)

How to find what cause that error.

Regards,

Leszek

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Best Answer
    Posted on Apr 08, 2014 at 12:34 PM

    Hi,

    There is no issue with your process chain design.

    Problem with your process chain related application component.

    You transport need to have application component which was in active version.

    Assuming below is your transport procedure.

    dev ---> prod.

    So from dev system, collect your process chain again along with active application component and move to target system.

    Check your application was active or not at dev, if not active, make it active and recollect whole process chain into transport.

    once you collect your transport, please check your transport need to have two major objects.

    1. process chain technical name

    2. table - RSCOMPTLOGOT

    Thanks

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Apr 08, 2014 at 12:16 PM

    Hi,

    APCO is Application component. this is the group under which you process chain present.

    in the above picture "BI admin cockpit" is APCO of those 6 chains.

    You have to check whether your "DM" APCO is present in Production.

    you have to capture this and send to production before sending the chain, usually when we move Process chains whose APCO is not there, then the chain will go into Unassigned.

    -Sriram


    Capture.PNG (14.2 kB)
    Add a comment
    10|10000 characters needed characters exceeded

    • (may be it is important)

      When I went /Process chain / Attributes / Display components in "display" mode the option "Display components" was not active). It became active after I changed mode to "change".

      At that moment I see there value Z_FI.

      and i think that's the proper value. We always use that value creating new chains for FI loads.

      I don't see any DM component to choose. We use Z* components.

      Should I search DM component in transport workbench then ? It may be difficult to find it.

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.