Skip to Content
0
Former Member
Apr 07, 2014 at 06:08 PM

Value not displaying at runtime

14 Views

Hi Experts,

We have a Source field <LineSequenceNumber> which is mapped to <LineNumber> at target side at Line Item Level. The <LineSequenceNumber> is occuring multiple times with same or different value but at target side <LineNumber> is appearing only for different value and not repeating for the same value.


Let me explain this scenario with an example. <LineSequenceNumber> is repeating 4 times in at source side. Two times with value as 1 and Two times with value 2. after executing the mapping <LineNumber>1 is appearing for first occurence not for second occurence, same is with <LineNumber>2.

Now my requirement I want <LineNumber> should occur as per source. Do we need to write any UDF for the same?

Source Side

<ShipmentLine>

<LineSequenceNumber>1</LineSequenceNumber>

<PartNumber>XYZ</PartNumber>

</ShipmentLine>

<ShipmentLine>

<LineSequenceNumber>1</LineSequenceNumber>

<PartNumber>XYZ</PartNumber>

</ShipmentLine>

<ShipmentLine>

<LineSequenceNumber>2</LineSequenceNumber>

<PartNumber>ABC</PartNumber>

</ShipmentLine>

<ShipmentLine>

<LineSequenceNumber>2</LineSequenceNumber>

<PartNumber>ABC</PartNumber>

</ShipmentLine>

after exceuting the mapping

TargetSide

<LINE>

<LineNumber>1</LineNumber>

<PartNumber>XYZ</PartNumber>

</LINE>

<LINE>

<PartNumber>XYZ</PartNumber> (<LineNumber>1 is missing which is required)

</LINE>

<LINE>

<LineNumber>2</LineNumber>

<PartNumber>ABC</PartNumber>

</LINE>

<LINE>

<PartNumber>ABC</PartNumber> (<LineNumber>2 is missing which is required)

</Line>

Regards

Faisal.

</LINE>