Skip to Content
0
Former Member
Apr 07, 2014 at 06:46 AM

DB connect error

978 Views

Hi,

I changed DB users password using brtools and tried to UP the sap , unable to connect to DB

Listener is UP and running:

please help ASAP

R3trans log:

4 ETW000 R3trans version 6.24 (release 720 - 08.07.13 - 20:13:05 ).

4 ETW000 unicode enabled version

4 ETW000 ===============================================

4 ETW000

4 ETW000 date&time : 07.04.2014 - 12:27:05

4 ETW000 control file: <no ctrlfile>

4 ETW000 R3trans was called as follows: R3trans -d

4 ETW000 trace at level 2 opened for a given file pointer

4 ETW000 [ dev trc,00000] Mon Apr 07 12:27:05 2014 235 0.000235

4 ETW000 [ dev trc,00000] db_con_init called 68 0.000303

4 ETW000 [ dev trc,00000] set_use_ext_con_info(): rsdb/ssfs_connect not set => ssfs not used 65 0.000368

4 ETW000 [ dev trc,00000] determine_block_commit: no con_hdl found as blocked for con_name = R/3

4 ETW000 57 0.000425

4 ETW000 [ dev trc,00000] create_con (con_name=R/3) 33 0.000458

4 ETW000 [ dev trc,00000] Loading DB library 'dboraslib.dll' ... 54 0.000512

4 ETW000 [ dev trc,00000] DlLoadLib success: LoadLibrary("dboraslib.dll"), hdl 0, addr 000007FEE7E30000

4 ETW000 1151 0.001663

4 ETW000 [ dev trc,00000] using "E:\usr\sap\W09\SYS\exe\uc\NTAMD64\dboraslib.dll" 32 0.001695

4 ETW000 [ dev trc,00000] Library 'dboraslib.dll' loaded 34 0.001729

4 ETW000 [ dev trc,00000] function DbSlExpFuns loaded from library dboraslib.dll 33 0.001762

4 ETW000 [ dev trc,00000] Version of 'dboraslib.dll' is "720.00", patchlevel (0.425) 227 0.001989

4 ETW000 [ dev trc,00000] function dsql_db_init loaded from library dboraslib.dll 34 0.002023

4 ETW000 [ dev trc,00000] function dbdd_exp_funs loaded from library dboraslib.dll 53 0.002076

4 ETW000 [ dev trc,00000] -->DbSlControl(con=-1,cmd=47=DBSL_CMD_IMP_FUNS_SET) -> changed=30, tagset=1

4 ETW000 709 0.002785

4 ETW000 [ dev trc,00000] -->DbSlControl(con=-1,cmd=39=DBSL_CMD_SET_SINGLETASK) 36 0.002821

4 ETW000 [ dev trc,00000] -->DbSlControl(con=-1,cmd=10=DBSL_CMD_DBCA_PTR_GET) 35 0.002856

4 ETW000 [ dev trc,00000] New connection 0 created 30 0.002886

4 ETW000 [ dev trc,00000] 0: name = R/3, con_id = -000000001, state = DISCONNECTED, tx = NO , bc = NO , hc = NO , perm = YES, reco = NO , frco = NO , timeout = 000, con_max = 255, con_opt = 255, occ = NO , prog =

4 ETW000 65 0.002951

4 ETW000 [ dev trc,00000] -->DbSlControl(con=-1,cmd=10=DBSL_CMD_DBCA_PTR_GET) 47 0.002998

4 ETW000 [ dev trc,00000] db_con_connect (con_name=R/3) 28 0.003026

4 ETW000 [ dev trc,00000] determine_block_commit: no con_hdl found as blocked for con_name = R/3

4 ETW000 49 0.003075

4 ETW000 [ dev trc,00000] find_con_by_name found the following connection: 29 0.003104

4 ETW000 [ dev trc,00000] 0: name = R/3, con_id = 000000000, state = DISCONNECTED, tx = NO , bc = NO , hc = NO , perm = YES, reco = NO , frco = NO , timeout = 000, con_max = 255, con_opt = 255, occ = NO , prog =

4 ETW000 71 0.003175

4 ETW000 [ dev trc,00000] -->DbSlConnect(vers=-1, type=0, env='[default env]', usr='[default usr]', kernel dbsl='720')

4 ETW000 134 0.003309

4 ETW000 [ dev trc,00000] DIR_CLIENT_ORAHOME is not set as profile nor env. parameter. 335 0.003644

4 ETW000 Assuming using instant client with unspecified location.

4 ETW000 [ dev trc,00000] Register application info. 109 0.003753

4 ETW000 [ dev trc,00000] Oracle client version: 10.2.0.5.0, (dbsl 720 090813, UNICODE[2]) 9733 0.013486

4 ETW000 [ dev trc,00000] Detailed Oracle client (patch) info not available. 73 0.013559

4 ETW000 [ dev trc,00000] Default connection: tnsname ='W09' 34 0.013593

4 ETW000 [ dev trc,00000] -->oci_initialize(con=0, char='UTF16', nchar='AL16UTF16', nls=-1),uc_ln=2

4 ETW000 68 0.013661

4 ETW000 [ dev trc,00000] ➖ OCIEnvCreate(mode=16384=OCI_UTF16) returned 0 (for default NLS handle)

4 ETW000 7941 0.021602

4 ETW000 [ dev trc,00000] OCIHandleAlloc(OCI_HTYPE_ERROR, con=0, ErrHp=03C28760) 167 0.021769

4 ETW000 [ dev trc,00000] OCIHandleAlloc(OCI_HTYPE_ERROR, con=0, ErrBt=03C2A338) 118 0.021887

4 ETW000 [ dev trc,00000] NLS env. settings: lang=41004D00450052004900430041004E00 473 0.022360

4 ETW000 [ dev trc,00000] terr=41004D0045005200490043004100 95 0.022455

4 ETW000 [ dev trc,00000] char=55005400460031003600 46 0.022501

4 ETW000 [ dev trc,00000] Client NLS setting (by OCINlsGetInfo(con=0)): 'AMERICAN_AMERICA.UTF16'

4 ETW000 82 0.022583

4 ETW000 [ dev trc,00000] charset='UTF16', ncharset='AL16UTF16', UNI_ASC=FALSE 43 0.022626

4 ETW000 [ dev trc,00000] Logon as OPS$-user to get SAPSR3's password 301 0.022927

4 ETW000 [ dev trc,00000] Connecting as /@W09 on connection 0 (nls 0) ... (dbsl 720 090813, UNICODE[2])

4 ETW000 109 0.023036

4 ETW000 [ dev trc,00000] OCIHandleAlloc(OCI_HTYPE_SVCCTX, con=0, svchp=03C2A1F8) 87 0.023123

4 ETW000 [ dev trc,00000] Allocating server context handle 50 0.023173

4 ETW000 [ dev trc,00000] Attaching to database server W09 (con=0, svchp=03C2A1F8, srvhp=03C2EA68)

4 ETW000 130 0.023303

4 ETW000 [ dev trc,00000] Mon Apr 07 12:27:06 2014 1184022 1.207325

4 ETW000 [ dev trc,00000] OCIServerAttach(OCI_DEFAULT) failed with -1=OCI_ERROR 74 1.207399

4 ETW000 [ dev trc,00000] OCIServerAttach(OCI_DEFAULT) failed with SQL error 12541: 142 1.207541

4 ETW000 [ dev trc,00000] ORA-12541: TNS:no listener

4 ETW000 61 1.207602

4 ETW000 [ dbsloci.,00000] *** ERROR => CONNECT failed with sql error '12541' 53 1.207655

4 ETW000 [ dev trc,00000] set_ocica() -> SQL error code 12541 37 1.207692

4 ETW000 [ dev trc,00000] -->oci_get_errmsg (con=0, rc=12541) 35 1.207727

4 ETW000 [ dev trc,00000] OCIErrorGet -> SQL error code: 12541 73 1.207800

4 ETW000 [ dev trc,00000] ORA-12541: TNS:no listener

4 ETW000 68 1.207868

4 ETW000 [ dev trc,00000] SAPUSER error or connect error 99=DBSL_ERR_DB, oerr=12541. 40 1.207908

4 ETW000 [ dev trc,00000] DbSlConnect(con=0) -> orc=0, 99=DBSL_ERR_DB 33 1.207941

4 ETW000 [ dblink ,00000] ***LOG BY2=>sql error 12541 performing CON 79 1.208020

4 ETW000 [ dblink ,00000] ***LOG BY0=>ORA-12541: TNS:no listener 36 1.208056

4 ETW000 [ dev trc,00000] -->DbSlControl(con=-1,cmd=41=DBSL_CMD_RELINFO_GET) 55 1.208111

4 ETW000 [ dev trc,00000] -->DbSlControl(con=-1,cmd=14=DBSL_CMD_VERSION_GET) 64 1.208175

4 ETW000 [ dev trc,00000] -->DbSlControl(con=-1,cmd=50=DBSL_CMD_GET_PATCH_INFO) 47 1.208222

4 ETW000 [ dev trc,00000] -->DbSlControl(con=-1,cmd=13=DBSL_CMD_VENDOR_NAME_GET) 97 1.208319

4 ETW000 [ dev trc,00000] -->DbSlControl(con=-1,cmd=52=DBSL_CMD_GET_DBLIB_VERSION) 33 1.208352

4 ETW000 [ dev trc,00000] -> 'OCI_10201_SHARE, 10.2.0.5.0' 33 1.208385

2EETW169 no connect possible: "DBMS = ORACLE --- dbs_ora_tnsname = 'W09'"

regrds,

Siva