Skip to Content
Former Member
Apr 05, 2014 at 01:33 AM

Crystal Reports - 64bit when Previous Reports were 32bit



I have a 64bit question. To take a step back, I was using Visual Studio 2008 on a 32 bit Windows O/S. I was using the Crystal Reports that came with Visual Studio 2008 (I think that was just an option that you could install from the VS ISO).

Now, I'm setting up a new environment: Windows 7 Pro (x64) with Visual Studio 2013.

I grabbed CRforVS_13_0_9.exe - as it was just released. And I installed Crystal Reports. Toward the end of the install I got a dialog that said something of the effect: "Hey, we detected that you are on a 64bit O/S - do you want to install 64 bit"? (I wish I had the exact message now). So I installed, what I thought was that too (in addition to the 32 bit - as it didn't ask me about 64bit until it had already spent a few minutes installing "stuff").

In Control Panel I now see:

SAP Crystal Reports runtime engine for .NET Framework (64-bit)

SAP Crystal Reports, version for Microsoft Visual Stuido

(also, of note, my .NET Framework is 4.5.1)

As I mentioned, I have a ton of existing 32bit Crystal Reports Projects that I need to convert from VS2008 to VS2013. Microsoft runs a wizard to convert the projects, and you guys also had some Wizard to convert the projects from the older version of Crystal to this new one. Being that I'm on a 64bit O/S now, and I have 64 bit Crystal installed, what exactly is happening on this conversion? Is it trying to take that 32 bit project and convert it to a 64bit version? Should I have installed the 64 bit Crystal when it asked me towards the end?

I'm trying to figure out what that all means. Also, after taking a simple existing report, and converting it, and making sure it built - I ran it, and all I get at runtime is a "value cannot be null. parameter name: inputstring" message (fyi, this is through the web, not winforms). I have no idea what inputstring they are referring to, especially since these reports worked in the older environment.

Thank you.