Skip to Content
avatar image
Former Member

Empty CHIP Catalog while configuring a Sidepanel


Hi All,

I am new to NWBC and have been trying to configure Sidepanels for NWBC. The system is running on EHP 6 SP2. I am following a simple way of configuring Sidepanels to use standard CHIP Catalogs provided by SAP explained in the following link:-

http://scn.sap.com/community/erp/blog/2013/03/18/side-panel-for-sap-business-suite-2--adapting-sap-s-side-panel-content-and-creating-new-content

However, to add a CHIP to a page, when i try to open CHIP catalog, it fetches nothing and is empty.

I searched a lot to find out what could be wrong, but havent been able to find anything conclusive. I am out of ideas right now, so it would be great if anyone can help me in resolving this. Thanks.

Thanks again for the help!

Best Regards,

Anupama

empty catalog.JPG (30.7 kB)
Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

2 Answers

  • Apr 04, 2014 at 08:55 AM

    Hi Anupama,

    Have you completed below steps from the above document link

    Finally the role must be assigned to your user master data in order to show the side panel for the transactions (this must be done in the transaction SU01).

    The usual approach in test environments is to create roles which include the technical side panel role portion (the “side panel folders”) and the menu role portion (the “menu path”) in one role. This approach is described above and it has the advantage that roles can also be tested without assigning them to your user master data. You can test such a single roles with the transaction NWBC. A browser window opens and here you should enter your role name into the textbox next to “Other” field and click on the small SAP icon next to the role name in order to start NWBC for Desktop with this particular role.

    Hope this helps.

    Regards,

    Deepak Kori

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Deepak,

      The above mentioned step is done. The problem is, after creating the Z application config, when i navigate to Personalisation > Configuration... to add Chip to it from the Chip Catalog.. the Chip Catalog is empty and does not display any options.

      Regards,

      Anupama

  • avatar image
    Former Member
    Nov 20, 2014 at 01:30 PM

    Hi Anupama

    I encountered the same issue today trying to activate HR Renewal. I solved the issue by removing heavy roles from the user in PFCG. Since the issue was not having no Chips at all but too many so that a time out was the result. By removing unneccesary roles from the user, this Problem was solved.

    You could as well try the Web-Dynpro Component WDR_CHIP_CATALOG. After removing the heavy roles, the chip catalog was populated again.

    PS: when you look into SAP's coding for building the catalog tree it becomes pretty clear that with a great number of Chips this takes forever running thru this Kind of code.

    Good luck

    Christoph

    Add comment
    10|10000 characters needed characters exceeded