Skip to Content
0
Former Member
Apr 03, 2014 at 07:20 AM

Measure returns blank when called in "IF" inside Variable

14 Views

Hello,

I have 4.1 SP02 Webi report.

I have an aggregated measure (sum aggregation) inside the report.

The measure is inside a variable (Lets call it 'Calc').

'Calc' is inside another variable(Lets call it 'Disp'), which contains IF (According to Input Control value).

Inside the table I put 'Disp', and the measure returns empty (blank, no error).

When I try to add the Measure itself to the table, it displays the value correctly (aggregated according to the table's dimensions).

Even when I try to add the 'Calc' variable, the values of the measure are correct.

But when reffering one of them from the 'Disp' variable with an IF condition, it shows nothing.

1. I've tried to check for the result of the IF, it returns the correct value from the if\else conditions.

2. If the IF returns 1 or 0, the table displays the values.

3. I've tried "ToNumber()" on the measure inside the IF in the "Then" part, but it didn't help.

Anyone have any idea?

Thank you,

Benpo