Skip to Content
0
Former Member
Mar 29, 2014 at 07:51 PM

SAPSR3 password issue when installing NW731

301 Views

Hi Experts,

Hope someone can help me with this. I am trying to install NW731 on a windows 2008 server which already has ECC6 installed on it. The ECC 6 existing install is a network domain install and the new install of NW731 is a local domain install.

At the time of installation the installation stops at the Create ICM userstore phase with this error:

An error occurred while processing option SAP Enhancement Package 1 for SAP NetWeaver 7.3 > Oracle > SAP Systems > Application Server ABAP > Standard System > Standard System( Last error reported by the step: Process call 'F:\usr\sap\MBW\SYS\exe\uc\NTAMD64\saplikey pf=\\srvdc1127\sapmnt\MBW\SYS\profile\MBW_DVEBMGS01_srvdc1127 -install_first_temp K0327848492 XXXXXX' exits with error code 2. For details see log file(s) saplikey.log, dev_slic.).

This is what it shows when I look at the dev_likey:

Connecting as SAPSR3/<pwd>@MBW on connection 0 (nls 0) ... (dbsl 720 081211, UNICODE[2])

Attaching to database server MBW (con=0, svchp=0AA7E3F8, srvhp=0AA82CC0)

Sat Mar 29 20:19:06 2014

Starting user session: OCISessionBegin(con=0, usr='SAPSR3', svc=0AA7E3F8, srv=0AA82CC0, usr=0AA919B0)

Sat Mar 29 20:20:07 2014

OCISessionBegin(OCI_DEFAULT) failed with SQL error 3113:

ORA-03113: end-of-file on communication channel

Server handle (con=0,svchp=0AA7E3F8,srvhp=0AA82CC0) detached

*** ERROR => CONNECT failed with sql error '3113'

[dbsloci.c 14533]

***LOG BY2=> sql error 3113 performing CON [dblink 540]

***LOG BY0=> ORA-03113: end-of-file on communication channel [dblink 540]

*** ERROR => saplikey: failed to connect to the database. [saplikey_w.c 762]

I have run the below command to make sure the password is correct and have also used the SAPSR3 user to query a table which was successful.

brconnect -u system/<password> -f chpass -o SAPSR3 -p <password>

After running the above command I am able to log in and connect to Oracle DB using the above command and query tables.

I have also tried to start SAP through sapmmc and looking at the logs I see this:

C Starting user session: OCISessionBegin(con=0, usr='SAPSR3', svc=1515F818, srv=15160100, usr=1516F390)

C

C Sat Mar 29 21:03:25 2014

C OCISessionBegin(OCI_DEFAULT) failed with SQL error 1017:

C ORA-01017: invalid username/password; logon denied

C *** ERROR => CONNECT failed with sql error '1017'

[dbsloci.c 14533]

Would be grateful if someone can help me overcome this issue.

Also, is there anyway to see what password is being used by SAP to perform the setup using the user SAPSR3? This to me is the most likely cause of the issue.

Thanks in advance.

Regards,

Manish