Skip to Content
avatar image
Former Member

SAP Business One - External Access by web Browser

Hi, how´s it going? I got a problem with the browser service. It´s working within my network with the https://servername:8100/dispatcher and it´s working outside my network too with the same direction.

The thing is that is working because I modified the 'hosts' file adding:

187.x.x.x (myexternalIP)       Servername

But when I tried to access from https://187.x.x.x:443/dispatcher it doesn´t work. I tried both ways (inside and outside) and this error appears

while trying to invoke the method com.sap.security.saml2.cfg.metadata.SAML2MetadataTrustedIdP.getSingleSignOnEndpoints() of a null object loaded from local variable 'provider'

I´m sure that it´s not because of the ports, it must be related to Apache. I attach a image below, I hope someone could help me! thanks.

Regards

error.jpg (138.2 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Jan 19, 2017 at 09:38 PM

    I tried fixed it in the route "C:\Program Files (x86)\SAP\SAP Business One BAS GateKeeper\tomcat\conf" with the file SLD-Cconfig.xml, and put in the name server the external ip. Then restart the service of "SAP Business One Browser Access Server Gatekeeper" in one moment is run.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      I tried already but it gets worse :/ a message appears saying "SLD initialization failed" or something like that.

  • avatar image
    Former Member
    Jan 26, 2017 at 12:48 PM

    I'm having the same problem, could you resolve it?.

    Add comment
    10|10000 characters needed characters exceeded

  • Apr 10, 2017 at 10:10 PM

    You can check out my installation video here: https://www.youtube.com/watch?v=jmTyw0sqM6Y

    My SSL installation video here: https://www.youtube.com/watch?v=dhL6Z1fCKXU

    Good luck!

    Mike

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Mike,

      I have done installation the same way mentioned in your video.I have assigned two Public IP's each at gatekeeper server and my SLD Server. i am able to access it locally but when i try accessing from outside my network I redirects me to local IP of SLD server (https://192.168.x.x:40000/ControlCenter/...) and connection gets lost.

      Please help me SAP b1 Accessible from internet.

      Thanks and Regards,

      Aditya Asati