Skip to Content

SAP ECC SM58 error :No Beans listening for name IDOC_INBOUND_ASYNCHRON

Hello Expert ,

I am creating a interface IDOC to JDBC . I have done the ALE configuration both ECC and PI Side and I am using a IDOC_AAE adapter for IDoc . I configured the inboundRa as per Sap recommend document . Everything is fine from configuration side .But when i trigger the IDOC from ECC side , It is stck in ECC. I have checked the SM58 . it is showing below error :

"No Beans listening for name IDOC_INBOUND_ASYNCHRON"

I have read the sap blog for this issue but not found a good solutions.Still this issue is going on . Please let me know if any one facing same issue .

Regards

P.Singh


Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Feb 14, 2017 at 12:51 AM

    Hello All Expert

    I have resolved my "No Beans listening for name IDOC_INBOUND_ASYNCHRON" issue .I have changed the some module parameter.

    Soloutiion : Go to NWA --> Application Modules--->com.sap.aii.adapter.idoc.ejb.jar module --->IDocReceiverBean

    In this IDocReceiverBean change the Function name from n/a to * .

    I have changed this parameter and my issue has been reoloved after 2 months .

    Regards

    pankaj Singh

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 19, 2017 at 02:39 AM

    Pankaj,

    Does your sender IDOC_AAe channel has CallSapAdapter module in that , can you provide NWA logs for this.

    • Try Re-Starting the IDOC_AAE channel / JavaIdoc or inboundRa in NWA..
    • Try Re-Creating the New channel again.

    Br,

    Manoj

    Add comment
    10|10000 characters needed characters exceeded

    • Pankaj,

      Checking NWA logs would be helpful to get more trace.

      We used to restart the JavaIDoc/InboundRA adapter.

      And also check the TCP IP RFC destinations in ECC and inbound RA in PI system they should have the same program ID.And inbound RA should have all the required parameters.

      Br,

      Manoj