Skip to Content
avatar image
Former Member

How to undo "Set case to" on a column in the data foundation?

Hello,

I have a multisource universe currently pointing at only one database (Oracle). In the data foundation I right-clicked one of the columns named "Category" and selected "Set case to upper case". This broke the query with the following error: "Database error: [Data Federator Driver] [Server] The column name 'CATEGORY' could not be found in the table/alias: 'Table__1'. (IES 10901) (WIS 10901)"

I would like to undo this change but can't find a way to do it. The only options in "Set case to" are upper and lower case, with no option to go back to the original/default. How can I fix this without having to reimport the table? I read that you can tweak case-sensitivity settings in a .prm file but I would rather not change things at the filesystem level.

EDIT: I worked around it by changing the object in the business layer to use the original case of the column name. But is there no way to change back how it actually looks in the data foundation? A minor issue perhaps, but annoying.

Thanks.

Pedro G. Acevedo

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Apr 19, 2014 at 02:48 PM

    Hi

    i think you can't change the table or views field's ...if you want to make change try to create view's on the DB tables ...and define according to your requirements and use that view in the data foundation instead of base table.

    Add comment
    10|10000 characters needed characters exceeded

    • Hi

      We can make changes back using the Undo option.

      If you have selected Category ..and selected

      • Selected "Set case to upper case" CATEGORY
      • selected "Set case to lower case" category

      If you want the actual DB field Category use the option :

      Edit --> Undo Set (IDT)

      If it is still not change back to “Category” , just delete the table from Data foundation and add again to same table once again and create the joins



      Undo pic.png (37.4 kB)