Skip to Content
avatar image
Former Member

FTP connection parameters

Hi,

In the sender's FTP connection parameters you need to set the file name. Because I need to pick up multiple files, I used *.txt. It didn't work with *.txt, but it works with single file name like sample1.txt. What seems to be the problem?

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Nov 10, 2005 at 07:22 AM

    Hi Tapio,

    check that again, it should work (i used that * many times). If not, open a OSS call, may be there is a bug in your SP.

    Regards,

    Udo

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 10, 2005 at 07:59 AM

    Hi

    This is an input i got from OSS notes, check if it helps,

    "Q: I am trying to get the File Adapter to poll a file, which contains special characters (e.g., accented characters or umlauts) in its file name. However, irrespectively of the wildcard mask I specify in the File Adapter sender channel configuration, the file does not get picked up. Which configuration setting do I need to change to get my scenario working?

    A: Under certain operating system platforms, such as Solaris, the APIs used by the Java Runtime (JRE) are not Unicode-aware. Consequently, the JRE needs to be configured to correctly interpret the character set it receives from the operating system.

    This is configured through the "file.encoding" system property as well as the "LANG" environment variable.

    Make sure you set "file.encoding" to a character set (such as ISO-8859-1) that supports the special characters you would like to process. This system property can be configured by appending "-Dfile.encoding=<encoding>" to the Java VM parameters section of the SAP J2EE Config Tool.

    Additionally, you need to set the "LANG" environment variable to a locale that supports more than 7 bits, such as "de.ISO8859-1". The encoding you specify in the LANG environment variable needs to match the encoding set via "file.encoding".

    You can persistently configure the environment variable by setting it in the profile $HOME/.sapenv_$HOSTNAME.csh of the <sid>adm user: setenv LANG de.ISO8859-1"

    cheers

    Sameer

    Add comment
    10|10000 characters needed characters exceeded