Skip to Content
author's profile photo Former Member
Former Member

Finding EXPORT to an IMPORT FROM MEMORY ID

Hi Experts,

I need to know how to find export to an import from memory ID. I've read and tried all solutions in the net and still failed to accomplish this. I've already tried the following:

1. go to debugging mode by using the internal command /h

then click the goto menu->sytem areas->abap memory.

in the abap memory the datas are stored ..

- This shows some of the memory IDs but not all of them (The one I'm looking for is not shown). Plus, how does this help me find the code where the export is? Its just a list of memory IDs.

2. run this program (input string of memory id) to search for all instances. RPR_ABAP_SOURCE_SCAN.

- What If the memory ID is stored in a variable?


3. Check the code where there is IMPORT .... FROM ....

u can find 'CALL TRANSACTION' or 'SUBMIT' statement just before IMPORT statement.

- In my case, no such code exists.

4. Also I've found a program wherein this Memory ID is being exported.

- The problem is, I've put all kinds of breakpoints in it (External and session - Update debugging is On), and repeated the whole process countless times. The breakpoint is not biting, I'm guessing its not passing there.

5. Breakpoint at statement "EXPORT".

- I've already checked all export statements I'm passing at this transaction code. There is no export for the import memory ID that I'm looking for. Is it possible that there are RFCs and background processing that export this? By the way, Update debugging is on, so this should still be caught by the "breakpoint at statement". Also, this is only 1 transaction code. To my knowledge, memory IDs are stored per session. So I think this issue is mysterious.

Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • Posted on Mar 05, 2014 at 11:38 AM

    Hi Jack

    My 2 cents

    About point 2 if it is declared as a constant etc also it will be able to catch hold of this. Which transaction you are looking for is it standard or custom and which memory id..? Can you please provide more details..If its standard may be we can help

    Nabheet

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Mar 06, 2014 at 12:05 PM

    Jack,

    Check if the entries of the table INDX will give you any lead ?

    K.Kiran.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Nov 05, 2019 at 03:19 PM

    I had a similar issue. What i did is ABAP stack from standard tab in debug, opened each Object and did global search with the memory id. That helped. All other search reports/EXPORT statement break point failed.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.