Skip to Content
avatar image
Former Member

Problem in HA Configuration and ERS installation

Dear Experts,

I have planned to install a HA SAP ECC 6.0 System with Oracle DB.

I completely configured 5 Virtual Machines for this purpose, and at status quo, I have decided to install these components as mentioned below:

VM1: ASCS

VM2: ERS

VM3: DB

VM4: CI

CM5: DI

All machines run Redhat linux x64.

I started with installing ASCS on the first VM. It was successful; also I have configured the file system as described in the following link:

http://help.sap.com/saphelp_nwpi711/helpdata/en/27/44f17a26a74a8abfd202c4f5dc9a0f/content.htm

Then I tried to install ERS on the second VM (VM2).  The installation was able to find the profile which the ASCS has generated but finally it failed because it couldn't find some files:

sapinst_dev.log says:

TRACE      2014-03-02 15:00:23.858

NWException thrown: nw.noExecutableFound:

Cannot find executable sapcontrol at these locations: /usr/sap/SHP/ERS10/exe/sapcontrol, /usr/sap/SHP/SYS/exe/run/sapcontrol, /usr/sap/SHP/SYS/exe/uc/linuxx86_64/sapcontrol.

As a result, I decided to try another plan by installing another ERS on the first VM and it completed successfully.

Now, I have ASCS and ERS on the VM1, but I cannot install ERS on the VM2.

The question is:

1.Since I don’t want to have any SPOF, which one of the following solutions is correct?

  • Solution 1:
    • VM1: ASCS
    • VM2: ERS

  • Solution2
    • VM1: ASCS + ERS
    • VM2: ERS   

  • Solution 3
    • VM1: ASCS + ERS
    • VM2: ASCS + ERS

2.If you dont choose Solution 3 then; How can I solve the problem of installing ERS on the second node? Any idea

Regards,

Meysam Kermani

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Best Answer
    avatar image
    Former Member
    Mar 17, 2014 at 08:06 AM

    check if all you have assigned proper hostnames, IP address and maintain all the VM host entry details in /etc/hosts file of VM2.

    DB is a SPOF and you should identify how you will eliminate this in your solution. also look into how you will make the /sapmnt/<SID> filesystem a high available one

    regards,

    Chandru

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Mar 05, 2014 at 06:17 AM

    no idea about the topic?

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Mar 20, 2014 at 03:40 AM

    Hi Kermani,

    looking to your issue anyhow you are not able to install a single standalone ERS on VM2, hope I'm right.

    Go for third solution and see how it behaves.

    Regards,

    Deepanshu Sharma

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hello all,

      Recently I was installing consolidation system follow architecture which we use for all our production systems.


      Linux host #1 : NFS, Database and ASCS

      Linux host #2 : ERS

      Linux host #3 : Primary AS

      Linux host #4 : Secondary AS

      During ERS installation I got the same error as you:

      "Cannot find executable sapcontrol at these locations: /usr/sap/exe/sapcontrol..."

      It seems that sapinst did not create some things properly so I will write what I have done.

      From OS level ,on VM where ERS will be installed please execute:

      cd /usr/sap/<SID>

      mkdir SYS

      cd SYS

      mkdir exe gen src

      ln -s /sapmnt/<SID>/global global

      ln -s /sapmnt/<SID>/profile profile

      cd exe

      mkdir opt

      ln -s /sapmnt/<SID>/exe/uc/linuxx86_64 dbg

      ln -s /sapmnt/<SID>/exe/nuc nuc

      ln -s /usr/sap/<SID>/SYS/exe/dbg run

      ln -s /sapmnt/<SID>/exe/uc uc

      Then click retry in your window installation.

      I hope that it would help.

      Regards,

      Karolina

  • avatar image
    Former Member
    Jan 04, 2016 at 05:28 AM

    In solution 3, do they need to configure virtual IP address for ERS? or ERS doesn't need virtual IP address?

    - Jinkoo

    Add comment
    10|10000 characters needed characters exceeded

    • Hello Jinkoo,

      The ERS itself does not receive any connections. So, it does not need a virtual IP in any case.

      However, you should not have two ASCS instances running at the same time (as solution 3 suggests).

      The best approach is to have the ASCS in cluster.

      Then, you can decide whether to install one ERS at each cluster node and use scripts triggered by the cluster to control which ERS is the active one (it should be the ERS not running at the same cluster node as the ASCS) or you could put the ERS in cluster as well.

      The cluster should then control where the ERS is running (should be at the cluster node where the ASCS is not running).

      See Polling Concept - Standalone Enqueue Server - SAP Library for the cluster scripts concept. Your cluster partner should help with (or provide) the scripts.

      Cheers,

      Isaías