Skip to Content
0

Why would this table filter this way

Jan 18, 2017 at 01:38 PM

25

avatar image

Hi first thanks for your time!

I have a scenario.

Create a Query as follows

  • Result Objects
    • MRN- Organization
    • Age- Years (Current)
    • Birth Date
    • gender
  • Query Filters
    • Admit date prompt
    • Encounter Type:Inpatient
  • Select Run Query
  • When prompted, enter values then select Run Query
  • Select Edit Query
  • Right-click query tab, Rename to:qryBase
  • Right-click query tab, Select Duplicate Query
  • Right-click query tab, Rename to:qryAllergyDesc
  • Modify qryAllergyDesc as follows
    • Add Allergy - Description – Person nuts
  • Select Run Queries
  • When prompted, enter values then select Run Query
  • Select ‘Include the result objects in the document without generating a table’, Select OK
  • Create detail object for Allergy - Description – Person
  • Select the Variable Editor icon
  • Name:varAllergy-Desc
  • Qualification:Detail
  • Associated Dimension:MRN- Organization
  • Formula:=[Allergy - Description - Person]
  • Select OK
  • Drag and drop varAllergyDesc after the right most column of the table
  • Right click and format table
  • Check box for ‘Avoid duplicate row aggregation’
  • Select Edit Query
  • Select the qryBase query
  • Select Properties tab
  • Uncheck ‘Retrieve duplicate rows’ in the Data section
  • Select the query edit icon
  • Select the query properties icon
  • Uncheck 'Retrieve duplicate rows’ in the query
  • Select Run Queries
  • When prompted, enter values then select Run Query
  • The following is the table that results.

    Now when I filter the first column on 2106299133, I get the 2ndtable below.

    • Why are there 3 extra records in the table below after it’s been filtered to only show 2106299133?
    aliyl.png (43.1 kB)
    1ydnu.png (14.4 kB)
    10 |10000 characters needed characters left characters exceeded
    * Please Login or Register to Answer, Follow or Comment.

    2 Answers

    AMIT KUMAR
    Jan 18, 2017 at 02:26 PM
    0

    right click on the table->Format table->uncheck the checkbox "Avoid duplicate row aggregation" and check.

    Share
    10 |10000 characters needed characters left characters exceeded
    Scott Gilsdorf Jan 18, 2017 at 04:46 PM
    0

    When I do that I get "datasync" error.

    Share
    10 |10000 characters needed characters left characters exceeded