Skip to Content
avatar image
Former Member

The maximum connection limit has been reached. (Error: RWI 00000)


1) Inexperienced user

2) All was working perfectly with BI 4.1 SP1 FP1 2008R2 SP2 64bit (Don't know all the stats but it is a capable machine)

3) Upgrade to BI 4.1 SP3 FP3 and not long after starting SIA, dasboards and all webi reports throw "The maximum connection limit has been reached. (Error: RWI 00000)"

Not sure what happened but obviously some setting changed somewhere during the upgrade process. We have several dashboards updating every 2 minutes but they are receiving data from published BIWS scheduled instances. I don't believe that dashboards have anything to do with the issue. It I attempt to open the webi report being used as the web service I receive the maximum connection limit has been reached. (Error: RWI 00000). In fact I cannot open any webi report until I restart the SIA and after a few minutes I am down again. I have 8 web processing servers and each is set to 200 connections. I cant see how I would be even close to this as I have very few users that actually use launch pad. As I mentioned the system was running seamlessly without error until the upgrade to SP2 FP3. It is like the report instance is not being released or something. I am by no means a administrator of the caliber of folks that post here. We are a small organization and don't tax our system to often and it usually just works so I rarely have to deal with complex java heap configurations or things of that nature. Any help or suggestion of things to try would be greatly appreciated. I hope to have things working before work on Monday.

I am new to the SAP portal experience. If this post is not in the appropriate location will someone please direct me to where to handle these types of questions.

Thank you in advance,

Good Day To All

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • avatar image
    Former Member
    Mar 02, 2014 at 06:31 AM

    Make that upgraded to SP2 FP3 vs. SP3 FP3...

    Sorry about that.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Edit universe connection to "Disconnect after each transaction" by the following steps. 

      1. Log into Designer. 
      2. Open the universe. 
      3. Select File > Parameters
      4. Click Edit... button. 
      5. Click Next
      6. Set Connection Pool Mode to "Disconnect after each transaction". 
      7. Click Next
      8. Click Finish
      9. Save the universe and Export to Repository.

      In IDT change the "connection pool mode", under connection settings to "Disconnect after each transaction

  • avatar image
    Former Member
    Mar 04, 2014 at 11:56 PM

    thank you for the response. i am however some what reluctant to try this due to the fact that everything was running correctly prior to upgrading BI 4.1 SP1FP2 to SP2FP3. what could have possibly changed that put my system in a mild state of chaos.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      I cannot be sure of what would have changed myself however I believe you can give a shot and see whether it works. If it does not work you can revert the steps / settings to your previous settings.

  • avatar image
    Former Member
    Mar 10, 2014 at 06:08 PM

    This issue has is no longer present. It was determined that one particular dash board was somehow causing Tomcat7 to misbehave and eventually crash. When this was discovered the particular dashboard was removed from service and I have not had a problem since. Thank you for your responses

    Add comment
    10|10000 characters needed characters exceeded