Skip to Content

BO4 - Alias table has quotes in front of it when adding to idt tool unx

Hi,

Normally when we add an alias table to the idt unx data foundation layer generates a table without putting quotes at start and end.

In this case it has put quotes and in tetsing cauisng problems as given table name as table_1 instaed of alias name we have given it and want to see it generate correct table name

what causes this - how can we change it

table_1 - called official_issue_calendar but even despite we name it that when look in dat afoundation at tables calls it "official__issue_calendar"

Why is this and how can we stop it - other alias tables have been fine. Using idt tool bo4 sp08.

SELECT

MEDIA.ISS_ACTUAL_ON_SALE_DATE_M

FROM

MEDIA,

DW.LATEST_PRODUCT_MV,

CALENDAR Table__1

WHERE

( MEDIA.PROD_NUM=DW.LATEST_PRODUCT_MV.PROD_NUM )

AND ( MEDIA.ISS_OFFICIAL_ON_SALE_DATE=Table__1.DAY_DTE AND Table__1.DIMENSION_KEY = Table__1.DAY_ID )

AND

(

( MEDIA.ISS_HANDLED_MONTH_NUM_M = TO_NUMBER(to_char(trunc(sysdate),'MM')) )

AND

( Table__1.MMN_VALUE = TO_NUMBER(to_char(trunc(sysdate),'MM')) )

)

Thanks

Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • Best Answer
    Posted on May 19, 2014 at 01:58 PM

    Hi Philip,

    Did this proposed solution work for you?

    Best regards,

    Pavan Bayyapureddi.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Feb 28, 2014 at 02:05 PM

    Philip,

    Make sure you are editing the Derived Table in the Data Foundation layer.

    Double-check:

    • No Extra space
    • No illegal characters, such as "-"
    • See screen-shot below

    Regards,

    Ajay


    IDT_DT_Name.PNG (18.7 kB)
    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on May 15, 2014 at 10:08 PM

    I sort of found a work-around for this.

    Version: BI4 SP6 Patch 7

    1. Add the alias table.

    2. Rename it with name in UPPER CASE. Magic!! It works!!!😊

    3. Now you will see the table name without double quotes("") and also the show script shows the alias name and not like "table_1".

    Strange but that is how the tool is behaving.

    Before naming the alias table with UPPER CASE.

    After naming the alias table with UPPER CASE.

    😊


    Add a comment
    10|10000 characters needed characters exceeded

    • Update: The resolution is to change the Oracle.prm file.

      Go to the following location in the Business Objects installation folder in your computer.

      Create a backup of the current Oracle.prm file.

      Open the Oracle.prm file as administrator using Notepad.

      Then change the "DELIMIT_LOWERCASE" parameter to "NO". Save the file.

      Now, restart your IDT and you should be able to name your alias tables to either upper or lower case without any problem.😊

      ** It is important to know the Oracle.prm file because I had to already do two modifications to this file.

      There are two locations of this file.

      1. C:\Program Files (x86)\SAP BusinessObjects\SAP BusinessObjects Enterprise XI 4.0\dataAccess\connectionServer\oracle\extensions\legacy

      For the above issue only update the 'legacy' folder.

      2. C:\Program Files (x86)\SAP BusinessObjects\SAP BusinessObjects Enterprise XI 4.0\dataAccess\connectionServer\oracle\

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.