Skip to Content
avatar image
Former Member

Wireportserver.exe is consuming 100% cpu

Hi Experts,

We are using SAP BI 4.0 sp6 windows for our BO Application.From last week onwards we are experiencing system freeze as the WIreportserver.exe consuming 100% cpu.we have to manually kill it to make the system work again.Even restarting the servers doesn't help!

Sometimes this issue happens when if there are no user logged in.Recently there are no changes made to the server.Hence not sure what

might be the reason behind this.

Thanks in advance for your help.

Regards

Kishore

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • Best Answer
    avatar image
    Former Member
    Mar 04, 2014 at 06:03 AM

    Hi All,

    Thanks for all the suggestions.

    The issue was related to Webi cache.The BO Cache files were not able to perform optimally  because the path size of chars are more than 260 which is maximum limit for Windows.I have changed the path of data file to main folder in D drive to shorten the path size and now the issue is resolved.

    Regards

    Kishore

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      Are you able to explain what is the path you are talking about? is it the Path for a particular Web Intelligence Processing Server in the CMC? I am facing an issue with WIReportserver.exe consuming all memory for a specific report and I think this post points to the solution.

      Thanks in advance.

      Regards,
      Roxana

  • avatar image
    Former Member
    Feb 28, 2014 at 12:47 PM

    I would request you to confirm the below steps.

    1) If you are using Load balance then please increase the Load Balancer idle session timeout .
    2) Can you also do this test: Please do take backup of the file.
    1- Open folder : <Your BO install Folder>\Tomcat55\webapps\AnalyticalReporting\WEB-INF\classes
    2- Edit file : webi.properties
    3- Change the lines :
    #WID_FAILOVER_SIZE=10
    #WID_STORAGE_TOKEN_STACK_SIZE=10
    By:
    WID_FAILOVER_SIZE=0
    WID_STORAGE_TOKEN_STACK_SIZE=0
    4- Save ans close the file
    5- Restart tomcat
    6- check if the issue is resolved

    3) Purge the query and run the same one by one. Once it is done then refresh all the queries. With this we can get to know which query is causing the issue. If you find that few queries are taking long time then foloow the below steps for that specific queries:
    a. . Edit the report and go to Edit Query.
    b. At bottom you can see the name of the Query
    c. Right click on Query and click Duplicate Query. It will create a copy of the original query.
    d. And then delete the original query.
    e. Do the same step for all queries
    f. Run all queries and then test the issue again.
    4) Run the report in Webi Rich Client. If it works then Save the report with different name and in different folder. And export same in Repository. From the Infoview try to refresh the report.
    5) Please check if using Web mode is acceptable workaround.
    6) In Universe Designer> parameter> Controls, uncheck the option 'Limit Execution Time To' and 'Limit Result Set To' parameters. By doing this it will allow users to create queries that have not been tuned, run for extended period of time .
    7) It is always recommended to Schedule the report which are of large size instead of refreshing. I would suggest you to schedule the report to resolve the issue.

    ~Sujeet Sharma

    Add comment
    10|10000 characters needed characters exceeded

    • Hi,

      "...experiencing system freeze as the WIreportserver.exe consuming 100% cpu..."

      1. Do you know which webi report(s) that are trigger the WIREportServer to CPU spike?  If not, I'd suggest you to enable the Webi tracing to identify the troubled Webi report and its work flow.

      2. After the troubled Webi report and its work flow is identified, do you experience the same CPU spike if this report is open and refresh in a Webi rich client?

      At last, there is a webi related CPU spiking issue fixed on "ADAPT01713425 Description: When opening webi report in attachment the webiprocessingserver is taken 100 % of CPU forever.

      New Behaviour: the issue is fixed" on BI4.1 SP02 Patch2.

      Hope this helps,

      Jin-Chong

  • avatar image
    Former Member
    Feb 28, 2014 at 08:22 AM

    Do you observe any ghost sessions running in webi processing server metrics.

    How soon is the issue occurring. It seems as though the cache is not getting cleared.

    Disable your existing server and create a new WIPS. It might help.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 28, 2014 at 11:56 AM

    Hi,

    Are you facing issue continuously or having issue when particular report run?

    If it happens when the report runs, make sure that you don't have more no of Varbles/inputcantrols and format of the report.

    if it happen continuously , try to clear the Data folder  and restart the SIA.

    Delete contents under the Data Folder in order to clear Web Intelligence Cache

    <Install Directory>\SAP Business Objects\SAP BusinessObjects.XI 4.0 \Data Folder


    stop SIA and rename Data folder and start the SIA

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Mar 03, 2014 at 07:27 AM

    Sounds like Platform search is doing its job:

    Ghosts in the Database | EV Technologies, Inc.

    Add comment
    10|10000 characters needed characters exceeded