Skip to Content
author's profile photo Former Member
Former Member

install error: J2E already exists

I had to abort my first installation of the Java Sneak Preview, because my C: drive was running out of space. I am using a 2nd disk for the database. After carving out some more room on C:, I tried to cleanly and thoroughly wipe out all traces of the failed install before trying again. Unstalling MaxDB from Windows's Add/Remove Programs wouldn't work (I don't remember the exact error, but it was running the uninstall script with -all and reported it couldn't do this because I needed to get rid of an instance first ???). Since the database was on my removable D: drive, I finally got rid of it the old fashioned way: I reformatted the disk. I also deleted any trace of "J2E" I could find in the Windows XP registry. Nevertheless, my retry of the Sneak Preview install fails on a sapdb_db_create statement, with the root problem as reported in XCMDOUT.LOG that J2E already exists:

> Subprocess starts at 20051107193441

 Execute Command : d:sapdbprogramspgmdbmcli.exe  -R d:sapdbj2edb db_create J2E CONTROL,CONTROL
 Execute Session Command : exit

> Subprocess stops at 20051107193441

 ERR
 -24953,ERR_DBEXIST: database instance already exists

Since I literally wiped out the database, can anyone tell me where the installation is still detecting the existence of J2E? How can I get rid of all traces?

And since the initial problem I had was too little free disk space on my C: drive, and since I bought a second hard drive precisely to get around this problem, is it possible to direct not just MaxDB but the Was 6.40/J2EE Engine itself to my D: drive (it seemed to install on C:\usr\... without my having any choice in the matter)?

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Best Answer
    Posted on Nov 08, 2005 at 09:45 AM

    Hi,

    the first problem you faced during uninstallation ('get rid of an instance first') meant that you had to manually drop the instance first (using the dbmcli command 'db_drop').

    Apparently you now still have some remnants left of that very instance, or at least some Registry information of it.

    Could you try the following commands from the commandline?

    1. dbmcli db_enum

    2. dbmcli inst_enum

    Regards,

    Roland

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      FWIW, I run the 6.40 Sneak Preview on a 1.5GB laptop, so with 2GB, I'd think you were in fat city.

      Also FWIW, I remember one time when I was trying to install an earlier version (6.10?), I couldn't get it to go at all, until I went into the registry and removed every single thing that referenced SAPDB and/or the SID (I can't remember what it was - might have been "WAS"?). All this was after I had removed SAPDB, all the services, etc. Once I did that, the install went ok. Oh, yeah - I had to run a registry clean, too, to get stuff I missed when I was doing it manually. A real pain in the butt.

      Good luck - I know how frustrating it can be, and do sympathize.

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.