Skip to Content
avatar image
Former Member

Removing search Criteria Text in OVS search help.

Dear Experts,

I've created an OVS search help for one of the field in my screen. On click of F4 help for that field, It is giving pop-up screen with search criteria text. Can any one let me know how to remove that search criteria text in OVS search help.

PFB the snapshot for reference.

Pls help me to resolve the above mentioned issue .

Thanks

KH

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

5 Answers

  • Best Answer
    avatar image
    Former Member
    Mar 10, 2014 at 03:44 PM

    Hello Katrice,

    While you have an event handler with OVS data for an inout field. You might have seen there are phases like 0,1,2,3. So in when if_wd_ovs=>co_phase_1. you comment out following code as shown.


    ** ovs_callback_object->set_input_structure(

    ** input = ls_search_input ).

    Now, you will not get search criteria on F4 of any input field attached with OVS.


    Hopw this will solve your issue.

    Add comment
    10|10000 characters needed characters exceeded

  • Feb 25, 2014 at 07:38 AM

    Hi,

    Looks like you are using FPM GUIBB Search? If so, you have to omit the TEXT attribute in ET_FIELD_DESCRIPTION_ATTR and for wild card search.., pass SUPPRESS_PATTERN_SEARCH as abap_false.

    Regards,

    Kiran

    Add comment
    10|10000 characters needed characters exceeded

    • Hi,

      The reason for the search criteria text is by default the explanation quick help was set to your application/ by your admin.

      To disable that, Right click on OVS popup and select 'Hide Quick Help'

      Or set the application parameter WDHIDEMOREFIELDHELPASDEFAULT ( no more annoying 😊 )

      Hope this helps u,

      Regards,

      Kiran

      hide_help.png (30.3 kB)
  • avatar image
    Former Member
    Sep 25, 2014 at 09:50 AM

    Hi Katrice,

    If i am not wrong you want to hide that text which you marked in square box?. If so, then please find my screen shot below and "right click on the text and select Hide Quick Help". it will hide the search criteria text.

    I hope it will solve your issue. I believe i am very late to reply you sorry.

    Regards,

    Chetan Bappankar


    Add comment
    10|10000 characters needed characters exceeded

  • Feb 25, 2014 at 07:24 AM

    Hi KH,

    Are you using WDR_OVS component for OVS search help?

    Regards,

    Rama

    Add comment
    10|10000 characters needed characters exceeded

  • Feb 25, 2014 at 01:21 PM

    Hi Hawkins,

    If it is standard component can you share the name of the component.

    Thanks & Regards,

    Sankar Gelivi

    Add comment
    10|10000 characters needed characters exceeded