Skip to Content
0
Former Member
Feb 24, 2014 at 02:50 PM

Smart Work Manager for Maximo 7.5 Error - AddFieldWorkOrder

27 Views

Hello. I am running into an issue during sending AddFieldWorkOrder. The Agentry Server starts fine and I am able to log into the ATE and transmit correctly. The Data and Complex Data Tables load correctly. But when I create a new field work order and try to transmit I run into a server error. I have tried other transmit functions from the handheld to Maximo and am receiving similar errors. I believe there is an issue reading the application class files, but I cannot seem to resolve the issue. I have attached a portion of the Server-Agentry log where the error is listed, but it doesn't give a lot of info.

I have exported the jar files into the D:\syclo\WorkManager\ServerDev\Java directory and extracted the class files into the D:\syclo\WorkManager\ServerDev\Java\Syclo\maximomobile\ directory

Here is what I have listed for the agentry.ini classpath and nonStandardJavaOptions

classPath=C:/jdk1.6.0_45/jre/lib/tools.jar;./Java/businessobjects.jar;./Java/tva_businessobjects.jar;./Java/mboejbclient.jar;./Java/mbojava.jar;./Java/Agentry-v5.jar;./Java/S4MxWM-7.5.2.0.jar;./Java/ini4j.jar;./Java/icu4j.jar;./Java

nonStandardJavaOptions=-Djava.endorsed.dirs=D:\IBM\WebSphere\AppClient\java\jre\lib\endorsed -Djava.ext.dirs=C:\jdk1.6.0_45\jre\lib\ext;D:\IBM\WebSphere\AppClient\lib;D:\IBM\WebSphere\AppClient\plugins

Any assistance in the matter would be greatly appreciated.

Thanks,

Pete

Tags edited by: Michael Appleby

Attachments