Skip to Content
avatar image
Former Member

Product category in SRM local and replicated from the ECC

Hello experts,

We have been working with SRM and ECC for a while now and we have the following scenario:

1. Product categories are manually created in ECC

2. The same product categories are created in SRM (again manually) and are assigned to a hierarchy using COMM_HIERARCHY

This has worked for us until now as no replication was needed. Now we are looking into implementing the Plan Driven Procurement scenario and for this we will need to replicate the product categories from the ECC so that the materials can be replicated as well.

The trouble comes from the old historical data that is available in the system. Like shopping cart, because users will not be able to use the "Old Shopping Carts and Templates" option. This is heavily used in our company.

What happens if you delete a product category and try to oder a new shopping cart based on an old one, for the basic user nothing gets copied, while the purchaser gets the message <No authorization to purchase on product category ">

So now the question is, what do we do about this?

Has anyone been in this situation before? Or how would you handle this switch from the manual categories to the automatically replicated ones?

Thank you!

Cata

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

1 Answer

  • Feb 24, 2014 at 01:22 PM

    I am not able to understand the issue exactly even if the product category is replicated and manual entry also exists there should be double entry of product category in which case it should still be visible

    Why the user cannot see the product category could be maybe due to :

    1. Check in pposa_bbp ext attribute if prod cat is assigned .

    2, Check Define Backend System for Product Category if all categories are assigned .

    3. Check for COMM_HIERARCHY if you are using the category is in the hierarchy.

    4. Check the cat is maintained for what all languages and if it is the same as that of user logon lang

    5. Check the roles .. try by giving SAP_ALL access initially .

    Also check for product category allowed or not for user is called in UPDATE_ITEM_INTERNAL method from /SAPSRM/CL_PDO_BO_SC class.

    Method concerned is /SAPSRM/IF_PDO_CHECK_VALUES~CHECK_PROD_CAT_AUTHORIZATION from /SAPSRM/CL_PDO_CHECK_VALUES.

    let me know your comments .

    Add comment
    10|10000 characters needed characters exceeded

    • Well I dont use a FM coz I am not sure if it actually updates u can check though ..

      Check points 1 and 2 as I have mentioned in my reply above if it is the same scenario as what i have assumed in your case then ..

      Go to se16 , table BBP_PDIGP enter the entry for SC here GUID etc .. go to debug mode type /h in prompt bar and then click on the Entry for prod catg id it will show open the editor .. change the value of CODE from show to EDIT and u will see the entries would become editable and it should work ..and replcae for new GUID of prod category

      You may take help from an ABAPer for this .. its quite easy .. this is just a workaround but not a recommended approach .. Editing table has worked fine for me at many cases ..

      Let me know on your comments ..