Skip to Content
0

SUM deploy fails due to error CIM_ERR_FAILED on tc~sec~destinations~service

Jan 18, 2017 at 09:38 AM

212

avatar image

Dears

we are performing on a Java only system the Ehp installation to this target release:

EHP3 FOR SAP SRM 7.01 (07/2016)

SAP SRM 7.0 / NW7.01 (06/2016)

SAP MDM CATALOG MGMT. 7.02 (06/2016)

SAP NETWEAVER 7.4 (06/2016)

We are using SUM sp18 for the update. We calculated the stack with Maintenance Planner, the system has been Verified by MP.

The SUM tool is running the EXECUTION module, but it encontered an error in phase Deploy DB Content and it is stopped now. Into the deploy_api.0.trc file we found this:

"com.sap.ASJ.dpl_api.001224###C0000AF40831000000009BB54F1BEB18###com.sap.engine.services.tc~bl~deploy~api#####d4a6f58409ef1000ad20fc25c5fccce8###Thread[Thread-12,5,main]#Plain##Could not establish connection to AS Java on [hostname:50604]. Error. Server process is down or disconnected from ICM. Check server process traces and ICM logs for details. Error message: the requested server is not available. Check if the host and port specified are correct and AS Java is up and running.#"

Despite in MMC we see the system in Green, from the C:\usr\sap\SID\J01\work\st_server0.out we see the system is not able to come up properly because it fails the start of the tc~sec~destinations~service :

"Service [tc~sec~destinations~service] start ================= ERROR ================= CSN Component [BC-JAS-SEC], DC Name [sap.com/tc~sec~destinations~service]com.sap.engine.frame.ServiceException: [com.sap.ASJ.dest.sv0159] An error occurred when trying to initialize the CIMOM service where the destinations are stored. The error was CIM_ERR_FAILED: The SQL statement "SELECT "APPL","NA_HASH","NA_KEY","TYP","ACTIVE","RANK","CL_START_ID","HOSTNAME","NAMESPACE" FROM "BC_SLD_NAMESP" WHERE "APPL" = ? AND "TYP" = ?" contains the semantics error[s]: - 1:31 - the column >>TYP<< is undefined in the current scope - 1:36 "

After this all the subsequent services cannot be started due to hard references, so the instance does not come up properly , and the deploy fails.

The system uses a remote SLD that is up and running.

The error seems very similar to which one described in note :

1311201 - Upgrade to 7.11 SP1: Error when starting CIM service

But this note is quite old , is it still applyable ?

If yes which components do we have to re-deploy using ForceMode=True ?

We see that or EPS\is directory is empty

Any other suggestion ?

regards

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
Matt Fraser
Jan 18, 2017 at 07:54 PM
0

Hi Roberto,

First off, I updated the tags on your question, as this is really about SUM and the upgrade process, not so much the Java application server platform (though that's still relevant).

This may seem silly, but have you tried simply repeating the phase in SUM where the error occurs? It has been my experience that a number of these kinds of errors occur during upgrades, and often it's just a matter of timing in the process. Repeating the phase often corrects the error, so it's almost always worth a try before you spend a ton of time researching, and especially before you try any forced manual action.

Cheers,
Matt

Share
10 |10000 characters needed characters left characters exceeded
Roberto Mariani Apr 29, 2017 at 01:34 PM
0

Thanks for the feedback. Yes, the error was solved after 5 or 6 retry.

Share
10 |10000 characters needed characters left characters exceeded