Skip to Content
avatar image
Former Member

WEBI prompt not showing master data values from BW

I have a WEBI report from a BW query and it is not showing the values on the prompt if there is no transactions on the cube.

I can see the values if I run in BEX Analyzer with the variable setting to Master Data, but does not show in WEBI,

Example - the cost center has no transactions but If I change the variable to "Custom - Values in Master Data Table", I can see it on the variable screen:

In WEBI, it does not show on the LOV when I search.

I want to create publication settings (now) and I know that this cost center will receive posting next month...

This is BI 4.0 SP4, BW 730.

and the RDS1 settings for the infoobject :

Thanks for your help...

Rodrigo Silva

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

2 Answers

  • Best Answer
    Feb 19, 2014 at 01:59 PM

    Hello Rodrigo,

    for Web Intelligence to show the master data for the prompt the InfoObject needs to be configured accordingly and based on the screenshot the InfoObject is only configured for the Query Definition part to show the master data, which means for the Query Designer.

    When configured on the InfoObject, WEbI will use it as well

    regards

    Ingo Hilgefort, SAP

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 19, 2014 at 04:31 AM

    Are you using the Key Figures in the WebI Report? Then remove it and just use all Dimensions .. Create one more query in WebI with the Key Figures and all other Dimensions in it. .. Merge the Dimensions in the WebI.

    Check if this fixes the issue?

    Add comment
    10|10000 characters needed characters exceeded