Skip to Content
author's profile photo Former Member
Former Member

I cannot copy files to smbfs NAS drive with SLES-8 Linux - SAP


I mounted a filesystem onto a Linux SLES-8 server as follows:

As root

mount -t smbfs //IP/nas-back -o uid=orasid,username=user,password=userpw,rw /sich1

I tried this:

mount -t smbfs -o uid=orasid,username=user,password=userpw //IP/nas-back /sich1

INFO: Debug class all level = 1 (pid 27097 from pid 27097)

srv0002:/oracle/DA2/920_32/dbs #

I tried this also:

mount -t cifs -o uid=orasid,username=user,password=userpw //IP/nas-back /sich1

mount: wrong fs type, bad option, bad superblock on //,

or too many mounted file systems

srv0002:/oracle/DA2/920_32/dbs #

With no success.

srv0002:/oracle/DA2/920_32/dbs # uname -a

Linux srv0002 2.4.21-190-smp #1 SMP Tue Feb 10 01:07:03 UTC 2004 i686 unknown

srv0002:/oracle/DA2/920_32/dbs # cat /etc/*-release

SuSE SLES-8 (i386)


UnitedLinux 1.0 (i586)





DISTRIB_DESCRIPTION="UnitedLinux 1.0 (i586)"


I can copy 10 files with a size of 4096 but not one file with the size of 4097 bytes.

The filesystem has 465GB free

srv0002:/oracle/DA2/920_32/dbs # df -h /sich1

Filesystem Size Used Avail Use% Mounted on


2.0T 1.6T 465G 78% /sich1

srv0002:/oracle/DA2/920_32/dbs #

No brarchive or brbackup calls are possible.

Thank you for you help.


Message was edited by: Juan Reyes

Add comment
10|10000 characters needed characters exceeded

1 Answer

  • Posted on Feb 13, 2014 at 02:21 PM

    So it looks like you have 2 issues:

    1. you can't mount a share using smbfs?

    2. you can't copy more then 4 MB or 4 GB?

    Can you browse/mount the windows share from a Windows system? Can you copy a file from that same Windows system?

    Add comment
    10|10000 characters needed characters exceeded

    • I don't think you have any security issues to be concerned with if other systems using the same ID can write larger files to the share.

      Is there a quota coming into play with the Share, the Linux server in question, the network?

      Another consideration would be that perhaps there is a bug in smbfs or something else on the Linux server? Can it connect to other Windows shares and send more then 4 K?