Skip to Content
avatar image
Former Member

How to stop decimals appearing for a quantity field?

Hiya,

I have this field/column in my webdynpro:

It's nice but it always displays 3 decimals places - does anyone know how to suppress the decimals?

So that instead of 15,000.000 it shows just 15,000?

If it helps the binding in the context is to EKPO-MENGE i.e.:

Any help would be gratefully received!

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    Feb 12, 2014 at 06:16 PM

    Hi,

    It's an automatic conversion by system based on data type. If you don't want to show decimal places, create a packed data element with no decimals and assign it to the attribute. Then in the program do the conversion to remove decimals and assign it to the attribute.

    If it is of initial value( 000.00) you can set the formatting options. under properties of attribute in context change it to zeros as blanks.

    Regards,

    Kiran


    no_lead_zeros.png (25.2 kB)
    Add comment
    10|10000 characters needed characters exceeded