Skip to Content
author's profile photo Former Member
Former Member

Crystal Reports Web Report Viewer not Rendering Toolbar or GroupTree controls

I have had Crystal Reports 11, which has been running fine on our Windows 2003 Web Server. Here is a screen shot of a report in the web viewer....

However, when we recently migrated over to Windows Web Server 2008 the report viewer is not rendering properly. I am taking a guess that it has something to do with the fact that our new machine is 64-bit, but that is just a guess. Here is what the report looks like now...

You will see that the ToolBar and GroupTree are completely gone, plus the Row separators are missing. When I look at the generated HTML code I can see that all that structure is missing... it was never rendered.

I am hoping someone knows what I can do to get the report viewer working properly again. Thank you!

report_good.gif (49.2 kB)
report_bad.gif (19.8 kB)
Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Best Answer
    Posted on Feb 11, 2014 at 08:31 PM

    Crystal Reports 11 is not supported on WIN 2008. You may want to give CR 11.5 (XI R2) a try. See this blog on how to update your app and install:

    Where did all the Crystal Reports XI R1 and R2 fixes go?

    Other than that, upgrading to CR 2008 (v. 12.x) or SAP Crystal Reports, developer version for Microsoft Visual Studio (2010 / 2012) would be the next options.

    - Ludek

    Senior Support Engineer AGS Product Support, Global Support Center Canada

    Follow us on Twitter

    Add a comment
    10|10000 characters needed characters exceeded

    • We are using Crystal Reports XI R2 with .NET 3.5.

      I am having similar issue where the tool bar of Crystal Reports Viewer is not being rendered in IE11.

      We are sticking to usage of Crystal Reports XI R2, as later versions of Crystal Reports does not allow customization of report viewer classes.

      The strange thing is that everything works on our in house webserver in IE11 as well. It only does not work in a web farm environment externally.

      I would like to check if there any update patches to the above version that will make it compatible with IE11?.

      Thank you in advance,

      Vasavi.

      New issue, create a new post in Legacy SDK forum:

      SAP Crystal Reports - Legacy SDKs

      Don

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.