Skip to Content
avatar image
Former Member

WDA Table - Row is not getting selected. always first row selected

Hi,

I have one table where I have to select record and delete delete. But when I select the row, it always goes to first record. What could be the problem.

Regards

Venkat

screen 1.jpg (89.3 kB)
screen 2.jpg (131.8 kB)
screen 3.jpg (95.5 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Feb 11, 2014 at 02:41 AM

    Hi Venkat,

    As per your screen shots, it looks fine and first line is highlighted for first time as lead selection is set.

    I suspect, there is some event handler setting data to context node and hence the lead selection is initializing to the 1st row.

    Could you please check, if any event handler attached on action OnLeadSelect / OnSelect.

    Also, check if you are setting/binding data to context node in WDDOMODIFYVIEW( ) method 😉

    Regards,

    Rama

    Add comment
    10|10000 characters needed characters exceeded

  • Feb 11, 2014 at 06:41 AM

    As suggested, Please check the all code..

    This is can be because if you are repopulating the data.. 

    What is happening exactly.. 

    1. if you are selecting 3rd row, it selecting 1st row automatically without doing anything

    2. or if you selecting 3rd row, it selecting 1st row after adding/deleting new row..

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 12, 2014 at 06:11 AM

    Please check the code at on lead select  (action) of table  . . .  in debugging at delete code .  so u will know  where exactly  you did wrtong !

    try dis one .

    Add comment
    10|10000 characters needed characters exceeded

  • Feb 12, 2014 at 09:28 AM

    Hi Venkat,

    I had the same problem. There is a sapnote which may help.

    Check sapnote: 1363334 (german)

    Suggested solution:

    SAP NetWeaver 7.00

    Spielen Sie Basis Support Package 21 ein.

    Since we updated to support package 21 it works in my case.

    Add comment
    10|10000 characters needed characters exceeded