Skip to Content
-1

Is it possible to setup Eclipse & SAPui5 in Windows 10?

Jan 18, 2017 at 03:05 AM

320

avatar image
Former Member

Our scenario is we have a Windows 10 laptop, and we cannot use web ide due to some security & limitations. Is it possible to setup the sapui5 development kit & eclipse for Fiori apps/SAPui5 development?

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Jun Wu Jan 18, 2017 at 05:02 AM
-1

no issue, I think

Show 2 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi Jun Wu,

Have you tried it before?

0

yes,............

0
Boghyon Hoffmann Jan 21, 2017 at 11:28 PM
0

The documentation doesn't mention Windows 10 as a supported OS (Edit: it does now) but you can still install and run everything there seamlessly.

Edit: I was running

  • Eclipse: Neon.2 Release (4.6.2)
  • Java SE: 1.8.0_112
  • Windows 10: 1607 (Build 14393.693) 64-bit

Show 10 Share
10 |10000 characters needed characters left characters exceeded

Hi Boghyon,

Can you please tell me which version of eclipse and java are you using in windows10.

Thanks,

Palsaran

0
ComponentPrerequisite Eclipse PlatformMars (4.5), Neon (4.6) Operating System
  • Windows OS
Java RuntimeJRE version 1.7 or higher (Eclipse Neon requires Java 1.8), 32-Bit or 64-Bit

more -> https://tools.hana.ondemand.com/#sapui5

0

Thanks Vladimirs..Actually earlier it was working in windows7..then i moved to windows10..now i'm getting error..That's why asking in windows10 which version of eclipse and java required.if anyone using windows10 please let me know.

0
Just edited my original answer. What kind if errors are you getting?
0

I'm using eclipse mars(4.5) and java1.8..I'm getting below error

capture.png (26.9 kB)
0

It looks like you've tried to run 64-bit version of Eclipse and/or Java on a 32-bit Windows machine. I'd suggest to reinstall Eclipse and JRE (and set its PATH) according to your OS' bit system. Let us know if it worked.

0

Thanks boghyon..Actually problem in java8..mars 4.5 required java7..it's not supported for java8..so i've uninstalled java8..now its working fine.

Thanks,

Palsaran

1
A K
Palanisamy Shanmugam

If it is resolved, we recommend you to close this thread by marking correct answer. :)

1
Show more comments

That's good to hear that it worked out for you. But Java 8 on Mars wouldn't have been a problem as you can see on my screenshot running Mars with JDK 8:

1