Skip to Content
author's profile photo Former Member
Former Member

Activating XSOData Service Getting 'Unsupported datatype' Error message

Hi All,

I'm doing a extend application service.

For a table which having text and blob sql type in column. For this table I wrote a xsodata service and tries to activate it. Then it give

unsupported datatype 'TEXT' in 'table_name', column 'column_name'

unsupported datatype 'BLOB' in 'table_name', column 'column_name'

So I'm blocked with this error.

Kindly help me how to handle this text and blob datatypes in xsodata service.

Best Regards,

Desanth

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • Posted on Feb 10, 2014 at 11:16 AM

    Can you check the path you have provided in the odata definition?

    Also the RHS after data:: you would need to mention <schema_name>.<table_name>

    But you have mentioned only a table name, this could be one issue

    Add a comment
    10|10000 characters needed characters exceeded

    • Hello Experts,

      Need your help input and help to resolve the xsodata activation issue.

      I want to create a xsodata definition which will point a calculation view with a input parameter which can take multiple values in it.

      The service defination is

      service{

      "SAPCAR.views::CV_DC_AVAILABLE_STOCK_QUERY_TEST_12JAN" as "CV_DC_AVAILABLE_STOCK_QUERY_TEST_12JAN"

      keys generate local "GenID"

      parameters via entity "IP" ;

      }

      While activating it we are getting the bellow error.

      The error in activating the xsodata file gets removed once Multiple entries check box in Input Parameter definition is removed(input parameter for single value is selected.)

      Definition of the input parameter is given below.

      When performing data preview from HANA studio ,I am able to view data and the generated sql is also provided below.

      SELECT TOP 200 "SAPClient", "Article", "Location", sum("AvailableStock") AS "AvailableStock" FROM "_SYS_BIC"."SAPCAR.views/CV_DC_AVAILABLE_STOCK_QUERY_TEST_12JAN" ('PLACEHOLDER' = ('$$P_Article$$', '''260342953065''') ) GROUP BY "SAPClient", "Article", "Location";

      SELECT TOP 200 "SAPClient", "Article", "Location", sum("AvailableStock") AS "AvailableStock" FROM "_SYS_BIC"."SAPCAR.views/CV_DC_AVAILABLE_STOCK_QUERY_TEST_12JAN" ('PLACEHOLDER' = ('$$P_Article$$', '''260203903140'',''260342953065''') ) GROUP BY "SAPClient", "Article", "Location";

      Thanks in advance for your valuable input.

      Regards

      Rohit

  • Posted on Feb 10, 2014 at 09:25 AM

    Hi Desanth,


    Can you give the code you have entered in your xsodata service?


    Regards,

    Mohan

    Add a comment
    10|10000 characters needed characters exceeded

    • Ho BLOB and TEXT data types must have not been supported . What is the kind of data you have for BLOB?

      And are those 2 columns required? You can remove those columns if not required and complete your oDATA definition if required.

        "sample.odata::table" as "MyTable" without ("Text","Time"); } 

      Check if you remove those columns if this is working or not.

      Regards,

      Krishna Tangudu

  • Posted on Mar 04, 2014 at 07:06 PM

    Hello Desanth

    I had the similar requirements. I am doing that with xsjs

    JSDoc: Class: PreparedStatement

    There are methods to set large object datatypes

    e.g

    setBlob(columnIndex, value)

    pstmt = conn.prepareStatement( "update <table_name> set <column_name> = ?")

    pstmt.setBlob(1,<value>);

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.