Skip to Content
avatar image
Former Member

SFTP Sender Channel Connection Error...

Hi,

i am working on scenario where PI needs to pick a file from the sftp server of our vendor. There are couple of vendors and i get same error in all the sender channels when i check communication channel monitoring.

In one of the sender channel i get as "Exception received: com.jcraft.jsch.JSchException: timeout: socket is not established" and


another sender channel error as "Exception received: com.jcraft.jsch.JSchException: Session.connect: java.net.SocketException: Connection reset"


I even tried increasing the TimeOut from 30000msec to 90000msec but still i am getting the error. Moreover the channel in DEV is working fine but in Production system its throwing error.




Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Feb 07, 2014 at 01:02 AM

    Hi Selva - For me it clearly seems like a network connectivity error.


    Make sure that the ports are open as it could be a firewall issue.

    You can try telnet to the SFTP server from PI system..

    How are you connecting? Key based? just with user ID&Passwords.

    Add comment
    10|10000 characters needed characters exceeded

  • Feb 07, 2014 at 01:25 AM

    Hi Selva,

    Please verify the following details:

    1) Private Key Password shouled be same as the password which is given while generating the key

    2) The user <SID>adm should have read access to the key root path

    3) Both extension of the public and private key should be recognized  by the PGP encryption module

    check this blog:

    http://scn.sap.com/community/pi-and-soa-middleware/blog/2012/04/10/pgpencryption-module-how-to-guide

    Check the firewall, as mentioned by Hareesh too

    Cheers

    Agasthuri

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 07, 2014 at 11:33 AM

    Hi Selva,

    The issue could be from the following.....

    1. firewall issue with the connection in your PI PRD system and SFTP server.

    2.Check if the folder permissions for your SFTP server are properly set, if you are archiving/deleting the file from SFTP server.

    Sometimes user level permissions are there and some times folder/file level permissions are set by SFTP admin.

    Add comment
    10|10000 characters needed characters exceeded