$(function () { pageContext.i18n.modTalk = 'moderation talk'; pageContext.i18n.replyToComment = 'Reply'; pageContext.i18n.modTalkEmpty = 'moderation talk is empty'; pageContext.url.getModTalk = "/comments/%25ID%25/listModTalk.json"; pageContext.url.possibleCommentRecipients = "/comments/%ID%/possibleRecipients.json"; pageContext.url.commentEdit = '/comments/%25ID%25/edit.html'; pageContext.url.commentView = '/comments/%ID%/view.html'; pageContext.i18n.commentVisibility = { 'full': 'Viewable by all users', 'op': 'Viewable by the original poster', 'mod': 'Viewable by moderators', 'opAndMod': 'Viewable by moderators and the original poster', 'other': 'Advanced visibility', 'dialogTitle': 'Comment visibility', 'selectGroups': 'Visible to groups', 'selectOther': 'Other recipients', 'selectOriginalPoster': 'Original poster', 'selectModerators': 'Moderators', 'selectAssignees': 'Asked to answer users' }; pageContext.i18n.commentMenuLabels = { 'comment-edit': 'comments.menu.edit', 'comment-delete': 'comments.menu.delete', 'comment-convert': 'comments.menu.convert' };pageContext.i18n.answer= { bestAnswer: 'Best Answer', controlBar : { accept: 'Accept', unaccept: 'Unaccept', acceptCommand: 'Accept this answer as correct', cancelAcceptedCommand: 'Remove this answers accepted status' } }; window.croles = { u: false, op: false, m: false, og: false, as: false, ag: false, dc: false, doc: false, eo: false, ea: false }; tools.init({ q: { e: false, ew: false, eo: false, r: false, ro: false, d: false, dow: false, fv: false, c: false, co: false, p: false, tm: false , ms: false, mos: false }, n: { f: false, vf: false, vfo: false, vr: true, vro: true, c: false, co: false, vu: false, vd: false, w: false, wo: false, l: false }, c: { e: false, eo: false, d: false, dow: false, ta: false, tao: false, l: false }, a: { e: false, ew: false, eo: false, d: false, dow: false, a: false, aoq: false, ao: false, tc: false, tco: false, p: false, tm: false }, pc: croles }, { tc: true, nsc: true }); commandUtils.initializeLabels(); }); Skip to Content

Fiori Admin Page Error

Dear Fiori Experts,

when I try to access the Admin Page I get the following error:

Error in OData response for GET "/sap/opu/odata/UI2/PAGE_BUILDER_CUST/Pages?$expand=PageChipInstances/Chip&$filter=catalogId eq '/UI2/TILES_CATALOG'&$orderby=title": HTTP request failed
Details: Model Error.


The browser shows that the “Catalogs are being loaded”:

I implemented the following components:

I applied all notes as mentioned in the SAP Installation Guide. The applications work fine without any error.


Any help is appreciated, thanks!


Regards,


Michael

image1.png (14.6 kB)
image2.png (16.3 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Feb 06, 2014 at 03:31 AM

    Hi Michael,

    Please try the program /UI2/CHIP_SYNCHRONIZE_CACHE.

    Is there any short dump in ST22?

    BTW, UI Add-on SP07 is available.

    Regards,

    Masa

    SAP Rapid Innovation Group - RIG

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 06, 2014 at 03:45 AM

    Please check and ensure Services are ACTIVE in GW System by going to SICF in GW system and then look for these services starting from "sap/opu/odata/UI2/" and activate them.

    Please check URL and provide that too in this post. does it start from https? or http? if https then replace by http and check is there a difference when you run the same scenario i.e ADMIN Catalog Page, as I am trying to isolate SSL related issues.

    Please check SAP Fiori LL11 - Consultants should know about OData troubleshooting and report back exact error by checking Chrome console. You can also see /iwfnd/error_log to see what is the actual error.

    thanks

    Ashish

    Add comment
    10|10000 characters needed characters exceeded

  • Feb 07, 2014 at 02:23 PM

    I went through some other checks now. All in all in the OData Service /sap/opu/odata/UI2/PAGE_BUILDER_CUST/ everything is working except for the entities:

    - Pages (model error)

    - PagesChipInstances (model error)

    - Chips (RFC Error)

    Any ideas?

    Add comment
    10|10000 characters needed characters exceeded

    • Thanks a lot for your support.

      I run through some tests (did some changes) and now it is running. Unfortunately I do not really know what leaded to solve the problem. But I did not install UI Add-on SP07.

      Thanks everybody for your help!