Skip to Content
avatar image
Former Member

Invalid server IDBC was used

Hi guys,

There is a very strange problem I ran into when I was implementing a task in MII. I have a new Oracle 11.2.0 database and I am trying to access it via XMII 14.0 (Service Pack 4, Patch 1). The "Invalid server IDBC was used" error I got when I tried to retrieve an iGrid table with data from the Oracle database.

Could there be a missing server instance in Netweaver? Tell me if I should provide more information.

Any help would be appreciated!

Thanks in advance!

Best,

Yavor

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Feb 06, 2014 at 09:11 PM

    This could be a harmless error message produced by a query execution where server is blank, and it substitutes the old 'default' SQLQuery based connected named 'IDBC'  (stood for Illuminator Database Connection - or something like that).  It could be from the workbench running a TableList query to populate the panel, or something along those lines.  Perhaps the iGrid with a blank query also might cause this when it tries to determine the list of data columns you have to choose from for data mapping.

    If you have never had an actual dataserver called "IDBC" then likely it's a remnant or a gremlin from the past or simply an empty/missing query template.  If you see it repeatedly in the NW logs, then perhaps you can pinpoint it, but might not be worth the effort.

    Regards,

    Jeremy

    SAP Rapid Innovation Group - RIG

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Strangely, I fixed the issue by a new import of the project. Perhaps the modifications I had made on the old objects were causing some inconsistencies, so it paid off to delete the problematic objects and re-import them (or the whole project, just to be on the safe side). Luckily, there were not so many grids and queries in my case. The problem hasn't appeared since then.

      Thank you all for the support!

  • avatar image
    Former Member
    Jan 30, 2014 at 08:08 PM

    Hi Yavor,

    Is your IDBC server which you are using to connect to Oracle database running?

    Check the status of the server in the data server screen.

    Regards,

    Rohit Negi.

    Add comment
    10|10000 characters needed characters exceeded