Skip to Content
avatar image
Former Member

sales order default crystal report...

hi..

have a look on below image..

i creae a crystal report from sales order rdr1 and ordr

and i put on parameter like docentry crystal report will come..

i put under sales order electronic report.. working fine...

but

The same report i had put at the layout management i had imported under order(items)

and then i put default report for sales order.

in sales order ok mode i click the print button..

plz have a look on below image..

it is asking the parameters.... nothing but docentry...

without giving the parameter is it possible to display the record

in pld it is not asking anything....

i cystal report it is asking..

is it behave currectly....

with out giving any parameter how to pass parameter .......in crystal report.

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

3 Answers

  • Best Answer
    avatar image
    Former Member
    Feb 01, 2014 at 03:26 AM

    Hi Srinivas,

    Did you check my solution??

    Still is there any issue??

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 31, 2014 at 11:28 AM

    Hi SriNivas,

    Again i am giving you step by step snapshot you have to use as it is. I have used your same query and finally problem solved.

    Step1. I have used your given query in CR. Please follow it properly...

    Step 2:

    Evertime we doing same mistake we r using DocEntry@ Parameter but here we have to use DocKey@ parameter as given in Snapshot.. Please follow it...

    Step3 : Please check the properties of Parameter with given screenshot..

    Step 4: Once Your Parameter Added you have select it and right click on it and you have to choose "Find in formula"option.

    Step 5: When you click on "Find in formula" option then new screen will open "Report Selectionformula editor" follow the steps given Below...

    First Select Record Selection then After that Double click on "Command.DocEntry" then Put "=" Sign then Click on "DocKey@". For Your Refernce please follow the screen shot...

    Save Your CR and Open Sales Order.


    1.JPG (145.0 kB)
    3.jpg (147.3 kB)
    2.jpg (164.5 kB)
    4.jpg (137.7 kB)
    5.jpg (100.6 kB)
    5-1.jpg (21.4 kB)
    5-2.jpg (25.9 kB)
    6.jpg (106.7 kB)
    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 30, 2014 at 12:43 PM

    Hi Srinivas,

    Create the parameter as Dockey@

    In filter use docentry and select the parameter.

    Find the screen shot for your reference

    regards,

    Anand


    Untitled.png (62.2 kB)
    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi,

      I have checked your issue in my system. Now it is not asking about paramter when i open sales order screen and click on preview button.I'll suggest you to use DocKey@ Parameter instded using DocEntry@. Once you added it. Goto it's "Find in Formula Option" and link DocEntry with DocKey@ i.e (Command.DocEntry={?DocKey}. It'll solve you problem.