Skip to Content

Memory issues on Production system

Hello,

We are facing memory dumps and slow SAP performance on our PRODUCTION ECC EHP4 system.

Many work process also goes to PRIV mode frequently

But we have very good response Time also.

I checked ST06 and see,

CPU Idle % = 40%

IO wait % = 16%

CPU count = 8

Number of request waiting to get processed in

1 Min = 7

5 Min = 6

15 Min = 6

We have Physical memory = 50GB

Free Memory only = 300 MB

We have following parameter set in RZ10

em/initial_size_MB = 4 GB

ztta/roll_extension = 2 GB

abap/heap_area_dia = 5GB

abap/heap_area_nondia = 5GB

abap/heap_area_total = 10 GB

rdisp/wp_no_dia                             20

rdisp/wp_no_btc                             8

Please guide

Regards,

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • Jan 30, 2014 at 01:36 PM

    Hello

    Having workprocess getting into priv mode is not always a problem, the bad point is that the workprocess is then dedicated to the current user.

    It can get worst f the user keeps it's trnasaction open for a very long time and keep the workprocess stuck...

    With the configuration you have that means that the process has already allocated 6Gb of memory, this is quite a lot but not insane.

    This is really becoming a problem if you have many process stuck in PRIV and all other process gets busy.

    You can detect this by checking the process queue in SM51 / goto / server name / Information / queue info

    => according to the low level of process queue there is no major impact.

    But it can be good to investigate & identify the prog / transaction that cause this behavior.

    Check if user selection are appropriate (not too wide) and in case of custom program  have a look at the ABAP.

    What is your OS ?

    Regards

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Jigar,

      Please update below configuration parameters

      em/initial_size_MB       8096MBem/blocksize_KB4096kBztta/roll_area3000000Byteztta/roll_first1Byteztta/short_area3200000Byte

      em/global_area_MB       250 MB

      Compare your parameter values with the one listed above. If possible update above recommendation in your system. Then execute sappfpar check=<path of instance profile> to adjust the shared memory segments.

      Hope this helps.

      Regards,

      Deepak Kori

  • avatar image
    Former Member
    Jan 30, 2014 at 02:26 PM

    What memory dumps?

    Check ST02 also.

    Thanks.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 31, 2014 at 08:51 AM

    First investigate your storage subsystem performance. Can you provide output of vmstat command?

    Add comment
    10|10000 characters needed characters exceeded

  • Feb 09, 2014 at 11:38 PM

    To avoid PRIV mode you should increase the Extend Memory areas.

    Regards

    Clebio Dossa

    Add comment
    10|10000 characters needed characters exceeded

  • Feb 11, 2014 at 11:52 AM

    Hello,

    I increased the Extended Memory to 16Gb

    And decreased the Heap memory by 2Gb

    So for now, As I check over Two weeks , I dont have any Wp's in PRIV mode.

    Thanks,

    Jigar

    Add comment
    10|10000 characters needed characters exceeded