Skip to Content
avatar image
Former Member

Personas - Labels being cleared after most recent Note implementation

This thread was started in reference to comments located here:

http://scn.sap.com/community/gui/blog/2013/07/10/personas-scripting

It is happening with all buttons on all screens now. However, upon further investigation, it is only clearing out labels. Textboxes remain unchanged.

If a button runs a transaction behind the scenes without leaving the cockpit, when it is finished executing, all output labels are reset to empty.

In the following video, there is a label that is hiding fields in that large blank area. When I click the GO button, nothing happens because GO checks for errors before any transactions are run.

But when I click the Search Button, the xk03 transaction is run in the background. When the script completes, data is returned to the three output labels within the Vendor Lookup group box, but all other labels are cleared, including the label hiding all the fields.

Again I click GO and nothing changes because no transaction is executed.

When I click Run Report - the ZPROP report is run and errors are returned to the home screen, and again, all other labels are cleared, but the textboxes are unchanged.

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Jan 24, 2014 at 09:29 AM


    Hi Cheryl,

    Thanks for opening this discussion. I see similar problem at our end too.

    My scenario is retrieving Personnel Number details from PA30 transaction and paste them on a remote screen that is designed to display all the details on a single screen with push of a button.

    I see the values are cleared out for labels as well as drop down fields.

    Regards,

    Geetha

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Cheryl,

      I am developing the same flavor kind of flavor as you discussed above for PA30 transaction. I am bringing the data from 8 Infotype to initial screen of PA30. I have turned off the Object Manager also, than also the script is taking about 30 seconds to bring data and populate the fields. The kernel is also updated with patch level 300. Is there any other thing that I can do to improve the speed.