Skip to Content

SAP MM MIRO Error [00065 (Enter date in format __.__ .____ appears.)]

Hello,

When i use Miro transaction for creating PO invoice, I get this error in MIRO about [00065 error message (Enter date in format __.__ .____ appears.)]

What things that this error was caused ? How i solve this problem ?

Thanks for helps.

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

7 Answers

  • Best Answer
    Jan 25, 2014 at 02:03 PM

    Hello again,

    Thanks everyone for helping.

    O solved problem and posted PO invoice correctly by customizing some value in my company code.


    91.jpg (178.6 kB)
    92.jpg (167.7 kB)
    93.jpg (160.5 kB)
    96.jpg (167.9 kB)
    Add comment
    10|10000 characters needed characters exceeded

  • Jan 23, 2014 at 04:37 PM

    I hope your date format is 00.00.0000

    As of today, please enter the date like as 23.01.2014.

    Go to SU3

    Check your Default date format.


    ScreenShot.jpg (51.0 kB)
    Add comment
    10|10000 characters needed characters exceeded

  • Jan 23, 2014 at 07:52 PM

    I would say that this is caused by an error in the screen variant.

    This error and a solution is described in OSS note 319555 - MIRO: Error: Enter date in the format &


    Since you do not even have access to SU3, you probably do not have access to the OSS note either and you cannot fix this error yourself. You have to contact someone who is in charge of customizing and implementation of OSS notes.

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 23, 2014 at 09:51 PM

    Hi,

    The date format is DD.MM.YYYY only, since the base line date (which is pulled by default and greyed out in MIRO) visible in your screenshot is in this format.

    The error you are facing in MIRO is because of the inconsistency is screen variant. Go to OLMRLIST (get the authorization from BASIS team if you dont have). Enter the following details in the initial screen:

    Transaction : MIRO

    Screen variant: <screen variant with description 'Invoice Reduction training"' in your case> (It is the layout visible in MIRO - as shown in your screenshot. For example: "6_6310")

    Program : SAPLMR1M

    Screen: 6310

    Now, click on the change button. Now, check whether any field is available with "content" as "____" or similar. Remove the W.content tick mark for all these type of fields and save the variant.

    Test again in MIRO.

    Please check the note: 319555 - MIRO: Error: Enter date in the format & for more details.

    Regards,

    AKPT

    Add comment
    10|10000 characters needed characters exceeded

    • Hi,

      Did you change the screen variant as explained in my previous comment? Please go to the transaction: OLMRLIST and change the screen variant as explained.

      Change the configuration and test again and revert back.

      Regards,

      AKPT

  • Jan 23, 2014 at 04:49 PM

    Hi,

    I faced same issue & there was a problem in MIRO screen variant.

    I used bellow procedure

    1. T-Code: OLMRLIST

    2. Give details as like

    Transaction : MIRO

    Screen variant: <Select for MIRO>

    Program: SAPLMR1M

    Screen: 6310

    3. Find field : reference date & deactivate check-box "with contents" against it.

    Hopefully, the same solution helps you.

    Thanks,

    Bisweswar

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 23, 2014 at 11:47 PM

    Also I talk SAP system administrator and he said me "we can ONLY support the date format dd.mm.yyyy" at SU3

    Add comment
    10|10000 characters needed characters exceeded

    • your admin is technically not right, a little thought about the global players with plants around the world should already make him aware that this cannot be true.

      technically the date is stored YYYYMMDD in the database.

      The setting in SU3 is just for the correspondence between SAP and the user in front of the keyboard.

      I am using the German setting DD.MM.YYYY, my american colleague uses MM/DD/YYYY

      And SAP is accepting either way for the same document.

      Hence the SU3 settings are usually not the root cause of any error. Except the user enters a date different to the settings.

      And SU3 is a global setting for YOU. It affects all dates, but your screenshot showed already some date fields in the correct format, hence it could never be that wrong SU3 settings lead to the error you had.

  • Jan 24, 2014 at 04:16 AM

    Hi andirman

    select from the calender

    and see whether the format is in mm.dd.yyyy or dd.mm.yyyy


    miro calender.PNG (44.3 kB)
    Add comment
    10|10000 characters needed characters exceeded