Skip to Content
author's profile photo Former Member
Former Member

X-window problem with SAPGUI

Hi,

I'm trying to configure the SAP GUI correctly. I have it installed at /opt/SAPClients on Fedora 4. I can login as root (/opt/SAPClients/SAPGUI6.40rev4/bin/guilogon) and it starts just fine-- but then under Add New Connection, only (none) is displayed in the System dropdown box. How do I get it to recognize the system? I started the other stuff fine using sapstart nw4host.

When I su to nw4adm or kevin (a local account), the GUI will not even start, and I get the following error:

Xlib: connection to ":0.0" refused by server

Xlib: No protocol specified

Exception in thread "main" java.lang.InternalError: Can't connect to X11 window server using ':0.0' as the value of the DISPLAY variable.

I think this is a conflict in X-windows-- does anyone know how to resolve this?

thanks,

Kevin

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • author's profile photo Former Member
    Former Member
    Posted on Oct 26, 2005 at 05:44 PM

    Solved. The problem is that you should give permission to other users (i.e. the

    superuser) to use your open graphical X console. To do that, use the "xhost"

    command. Once you log into the X environment, just open a text console and

    type:

    xhost +

    This give permission to any user on any machine to use your graphic terminal.

    Then, you can do "su" and run ethereal as root. When you log-out, the access

    permission is unset.

    Please, note that the previous command give permission to ANY user in ANY host

    to send windows to your grahical console. If you prefer to restrict the

    access only to users in the local host or to given users, please refer to the

    "xhost" command manual.

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      hi, i have read you chat and it has been very helpful, cos i had the same problem, but i could not get the window to work properly. i found somewhere i dont remember i couple of lines that have fixed my problem:

      export PLATIN_JAVA='<path where your java stuff resides on>/j2re.1.4.2_12/bin/java'

      export PLATIN_JAVA_VER='1.4.2'

      I had to execute every time i wanted to run java sapgui, so i just have added it into a script

      hope this helps

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.