Skip to Content

Issue with Design Studio SDK 1.2 Component development

I am using Eclipse Juno Java EE and Design studio 1.2 for developing custom components. I configured the SDK as mentioned in the DS 1.2 Dev Guide. The problem is the component works fine the first time i installed, but whenever we update the code and export and then install it in design studio still the same old component exists without updated. I tried all possible ways including uninstalling old component and also checked the source code in the created zip file. The code is updated in the package but not updating in Design Studio. We tried re-installing the software also but still no use. Am I making a mistake or is the issue with the new SDK ?. Because the procedures we did following the document worked fine in DS 1.2 beta version. Any help appreciated.

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Best Answer
    Posted on Jan 27, 2014 at 09:57 AM

    Hi Praveen,

    I have found that Design Studio doesn't completely uninstall the configuration files associated with an SDK component, so the new one doesn't get picked up. The approach that worked for me was to completely delete the contents of the following directory:

    C:\Users\<User Name>\Analysis-config

    This way, when you restart Design Studio it rebuilds a clean configuration without any references to old SDK components. If you then install the updated component you should find the new version is applied.

    Regards,

    Mustafa.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.