Skip to Content

SYNC SOAP scenario: Can't parse the document; HTTP 200 OK

Dear experts,

We are encountering the below issue in PI:

QoS:                         Best Effort (Sync)

Sender Adapter:         SOAP

Receiver Adapter:       SOAP, SSL not used

Frequency:                Intermittent, no pattern

The request message is received in the target system but the response message throws the error "can't parse the document; HTTP 200 OK". So, the response message contains only SOAP Header and SOAP Body, but no Payload.

No changes were done to this interface in the recent past. The issue started to occur abruptly.

Error Details:

We extracted the below trace from XPI Inspector:

Looking forward to your replies.

Thanks,

Manoj

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • avatar image
    Former Member
    Jan 20, 2014 at 10:19 AM

    Hi Manoj,

    Did you check if the response message leaves the system correctly before it arrives at PI?

    Also the XPI trace is missing. Can you please add it?

    BR

    Harald

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Manoj Ram Rajaram

      Hi Manoj,

      Did you manually check the service on the Portal system with the WS-Navigator directly on the Portal or by using SOAPUI as already recommended to call that Web Service? This helps to find out of the response is generally wrong or if there is a PI issue.

      Best Regards

      Harald

  • Jan 20, 2014 at 10:26 AM

    Hi Manoj,

    Try to test with SOAPui and compare the call with the PI call. That error uses to be an error page or similar in the endpoint the the PI can't parse an answer that is not a SOAP one.

    Regards.

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 20, 2014 at 10:34 AM

    Adding relevant screenshots:

    SXMB_MONI:

    XPI Inspector Log:

    Add comment
    10|10000 characters needed characters exceeded