Skip to Content
0
Former Member
Oct 25, 2005 at 02:01 PM

error in WAS ABAP+JAVA installation

16 Views

Hi all,

I have a notebook with WAS 6.40 ABAP stack running fine. Now I'm trying to install WAS Java stack (NW04 Sneak Preview SP11) in the same machine, but I always get this error in the 6th step of the installation process:

6th step: MaxDB Database Installation:

<i>ERROR 2005-10-25 15:41:59

CJS-00030 Assertion failed: in function sapdb_param_init(db_name, db_host, sapdb_version, inst_type) { var init_s; if (inst_type == undefined) { init_s = "OLTP"; } else { switch (inst_type) { case "LVC": init_s = "LVC"; break; default: init_s = "OLTP"; break; } } var r_arr = sdb_instance_type(db_name, db_host, init_s, sapdb_version); ASSERT(arguments.callee, r_arr != undefined, "SDB: ERROR EXECUTING PARAM_INIT!"); ASSERT(arguments.callee, r_arr[0] == "true", "SDB: ERROR EXECUTING PARAM_INIT! CHECK THE XCMDOUT.LOG FILE!"); return (r_arr[0] == "true");}SDB: ERROR EXECUTING PARAM_INIT! CHECK THE XCMDOUT.LOG FILE!</i>

I've tried several times. I've tried to start and stop the WAS ABAP and all SAP windows services and I always get an error. Before any installation I uninstall previous incomplete installation and I remove all registry entries.

During the SAPinst previous parameters pages, sapinst ask for "reinstall or reuse the SAP MaxDB Web Manager" (or similar). I've tried both options without success. Which is the correct option?

I need to install EP NW04 in the same machine that WASP WAS ABAP to configure the SLD and run a webdynpro application at the portal.

Can anybody help me?

Best regards.