Skip to Content
Former Member
Jan 15, 2014 at 06:45 PM

Duplicate data record detected when update to DSO....


I have to do one requirement to calculate the Time in job based on the Employee, position, job role and job stage. but here employee and cal month are the direct source fields, remaining fields are looking up in to Two other DSO's. So I wrote the code at End routine, the expected result will be the one employee might be more than one position, job role and job stage, but I got an error when i am executing the DTP that is - duplicate data record detected when updating to the DSO. actually there is no duplicate records with Key field combinations that is employee,position, Job role, Job stage and cal month.

I found only Employee and Cal month are the semantic keys at semantic group, I did not found any more keys which i mentioned in the DSO. key fields.

and I have tried with start routine also, same error facing , even i did not find any more keys at the semantic group,

one more surprised thing is I have opened the new data table at se11 and i checked the 5 key fields at new data table level, then it will be working fine,

and i got expected records. same thing i am not able to follow in production system with fire fighter access also.

any body please help me out on this.